Mon formulaire ne fonctionne pas!

cs_Larmes Messages postés 5 Date d'inscription jeudi 30 novembre 2000 Statut Membre Dernière intervention 3 juin 2007 - 3 juin 2007 à 00:56
SuperDevy Messages postés 842 Date d'inscription dimanche 24 novembre 2002 Statut Membre Dernière intervention 2 juillet 2007 - 4 juin 2007 à 20:02
J'ai fait un formulaire pour mon site. Mais il ne fonctionne pas.

Voici le code PHP :

<?php
$to = "mon@email.fr";
$subject = "$nom vous a envoyé un message ";
$msg = "Bonjour\n\n";
$msg .= "$nom vous a envoyé un message :\n";
$msg .= "$lemessage\n\n";
$msg .= "Si vous souhaitez lui répondre, voici l'e-mail et le téléphone de $nom\n";
$msg .= "$email\n";
$msg .= "$telephone\n";
mail($to, $subject, $msg, "From: $email\n");
?>

Et le code actionscript sur mon bouton :

on (release) {
    if (nom eq "" or email eq "" or telephone eq "" or lemessage eq "" or email.length<4) {
        stop();
    } else {
        loadVariablesNum("formulaire.php", 0, "POST");
        play();
    }
}

Dites moi ce qui ne va pas! Car j'y connais rien en PHP en plus...

Merci pour votre aide.

2 réponses

cs_Girou Messages postés 1203 Date d'inscription lundi 10 mars 2003 Statut Membre Dernière intervention 23 juillet 2009 2
3 juin 2007 à 14:47
Bonjour,

une première remarsue : eq n'est plus utilisé depuis flash 4 !!! utilise == à la place

Ensuite, pour le php renseigne toi au sujet des variables globale $_POST['variable'] car le script php me semble aussi très obsolete.
Fait une recharche sur flashkod (flash php) tu devrais trouver ton bonheur...

@+
0
SuperDevy Messages postés 842 Date d'inscription dimanche 24 novembre 2002 Statut Membre Dernière intervention 2 juillet 2007
4 juin 2007 à 20:02
Regarde du coté de cette classe, et du PHP qui va avec :
http://wiki.mediabox.fr/classes/flash/com/superdevy/interactions/sendmail

SuperDevy
0