Smartphone et MySQL

pikapote Messages postés 66 Date d'inscription lundi 13 mars 2006 Statut Membre Dernière intervention 11 mars 2014 - 1 juin 2007 à 14:06
cs_Stephane33 Messages postés 630 Date d'inscription samedi 15 février 2003 Statut Modérateur Dernière intervention 9 octobre 2011 - 4 juin 2007 à 18:14
Bonjour, je suis en train d'essayer de développer une application pour PDA (par Visual Studio 2005) qui utilise une base de données MySQL (déjà existante). J'ai des problème lors de la création des SQLCommand, SQLDataReader et SQLConnection.

Je vous fournis le code erreur, en espérant que vous puissez me donenr un début de solution  :
Erreur    1    Le type 'System.Data.Common.DbCommand' est défini dans un assembly qui n'est pas référencé. Vous devez ajouter une référence à l'assembly 'System.Data, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.    X:\Cours - EPSI\Ingé 2\Stage\Appli_Smartphone\Smartphone\Smartphone\MySQL.cs    124    37    Smartphone

Merci d'avance, et si vous possédez une solution complétement différente à celle que je souhaite faire, lâchez vous, je prends tout ce qui est bon à prendre

3 réponses

cs_Stephane33 Messages postés 630 Date d'inscription samedi 15 février 2003 Statut Modérateur Dernière intervention 9 octobre 2011 1
4 juin 2007 à 13:10
Des pistes !
1/ Tu rajoutes system.data en référence à ton projet,
2/Tu installes SqlCe sur ton Windows Mobile.

Le savoir ne sert que si il est partagé par tous
0
pikapote Messages postés 66 Date d'inscription lundi 13 mars 2006 Statut Membre Dernière intervention 11 mars 2014 1
4 juin 2007 à 13:40
Merci pour ta réponse !

La référence System.data est déjà dans mon projet (et j'ai vérifié la version , c'est la même que celle demandée)

De plus, j'utilise un émulateur pour PC, car pour le moment je n'ai pas encore le Smartphone. Est - ce que cela pourrait provenir de la version de mon émulateur ??? J'en doute ...
0
cs_Stephane33 Messages postés 630 Date d'inscription samedi 15 février 2003 Statut Modérateur Dernière intervention 9 octobre 2011 1
4 juin 2007 à 18:14
Verifie que SQLce est installé sur ton émulateur. Car visiblement tu as une bilbliothèque définie dans ton appli mais introuvable sur la machine Hôte (dans ton cas l'émulateur)

Le savoir n'est que le philtre de l'experience
0