Pb afficher une image

Résolu
coyote56 Messages postés 22 Date d'inscription mardi 29 mai 2007 Statut Membre Dernière intervention 19 mai 2009 - 29 mai 2007 à 19:03
coyote56 Messages postés 22 Date d'inscription mardi 29 mai 2007 Statut Membre Dernière intervention 19 mai 2009 - 30 mai 2007 à 10:37
Bonjour,
J'aurai aimé savoir comment on affiche une image sur visual basic 6.

J'ai mis ça :

Private Sub Form_Load()

Image.Picture = LoadPicture("C:\Documents and Settings\*******\******\****.bmp")

Mais cela ne fonctionne pas.

Merci, d'avance

7 réponses

jrivet Messages postés 7393 Date d'inscription mercredi 23 avril 2003 Statut Membre Dernière intervention 6 avril 2012 60
30 mai 2007 à 08:55
Salut,
>[auteurdetail.aspx?ID= 15669 EBArtSoft ][auteurdetail.aspx?ID=15669 , ]Je suis sous VB6 et sans le SET cela fonctionne très bien.

> [auteurdetail.aspx?ID=1074367 coyote56] En revanche ce qui ne fonctionne pas, c'est lorsque le controle est nommé "Image". Si tu le renommes cela devrait régler ton problème je pense.
@+: =89254 Ju£i?n
Pensez: Réponse acceptée
3
mortalino Messages postés 6786 Date d'inscription vendredi 16 décembre 2005 Statut Membre Dernière intervention 21 décembre 2011 17
29 mai 2007 à 19:10
Salut,

c'est quoi les étoiles ??
Suffit de mettre un chemin existant et ton image s'affichera.
Vérifie aussi le nom de ton contrôle image...

@++

<hr size="2" width="100%" />( Nouveau forum : Exclusivement Office & VBA )

  --Mortalino--
Le mystérieux chevalier, ~Provençal, le Gaulois~
                                                            
                                       
                                   
0
jmfmarques Messages postés 7668 Date d'inscription samedi 5 novembre 2005 Statut Membre Dernière intervention 22 août 2014 28
29 mai 2007 à 19:10
Bonjour,
Ne mets pas ton code (qui doit parfaitement fonctionner) dans l'événement Load de ta Form.
Load = charger et rien ne t'assure de ce qu'il a déjà chargé ton contrôle image au moment de l'exécution de ton instruction !
Pas dans l'événement Load, donc...
0
jrivet Messages postés 7393 Date d'inscription mercredi 23 avril 2003 Statut Membre Dernière intervention 6 avril 2012 60
30 mai 2007 à 07:54
Salut,
De plus au lieu de dire "Mais cela ne fonctionne pas."
Il serait plus judicieux de préciser si il y a une erreur ou non, si oui quel est l'intitulé de cette erreur?
Et oui en 2007 nous ne sommes toujours pas devins

@+: Ju£i?n
Pensez: Réponse acceptée
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
cs_EBArtSoft Messages postés 4525 Date d'inscription dimanche 29 septembre 2002 Statut Modérateur Dernière intervention 22 avril 2019 9
30 mai 2007 à 08:49
SET Image.Picture = LoadPicture("C:\Documents and Settings\*******\******\****.bmp")

sans le SET ça ne marchera pas (si tu es sous vb6)

E.B.
0
jmfmarques Messages postés 7668 Date d'inscription samedi 5 novembre 2005 Statut Membre Dernière intervention 22 août 2014 28
30 mai 2007 à 09:06
Salut Julien,

Ce coup-là avait échappé à mon attention !!!!

Cà, alors ! Tu as diablement raison.
0
coyote56 Messages postés 22 Date d'inscription mardi 29 mai 2007 Statut Membre Dernière intervention 19 mai 2009
30 mai 2007 à 10:37
Merci pour vos réponses.

En effet, j'ai renommé l'objet Image en I_Image !! et ça marche ;)

Merci encore.
0