Bug avec ADODB

Résolu
cs_reyman Messages postés 148 Date d'inscription mercredi 20 février 2002 Statut Membre Dernière intervention 5 juin 2007 - 28 mai 2007 à 10:01
cs_reyman Messages postés 148 Date d'inscription mercredi 20 février 2002 Statut Membre Dernière intervention 5 juin 2007 - 28 mai 2007 à 13:56
Bonjour j'ai une petite appli utilisant ADO qui marche tres bien sur divers postes mais qui plante sur mon serveur de dev.

Et apres divers tests elle plante sur cette ligne :
" Set Cnx = New ADODB.Connection"
sachant que cette variable est déclaré dans le programme "Dim Cnx As ADODB.Connection" et que la référence a ADODB est bien présente dans le projet.

L'erreur est la suivante : "Erreur -2147024770, Erreur automation, le module spécifié est introuvable"

Je suppose fort logiquement qu'il doit manquer un/des fichiers sur le serveur mais sauriez vous m'en dire plus??

D'avance merci de votre aide 

3 réponses

cs_reyman Messages postés 148 Date d'inscription mercredi 20 février 2002 Statut Membre Dernière intervention 5 juin 2007
28 mai 2007 à 10:54
Bon apres plusieurs lectures de forums, je me demande si c'est pas le MDAC en effet qui n'est pas a jour sur le serveur.
J'ai demandé l'installation de la version 2.8 sur le serveur, on verra si c'était ca.
Je reposterai un message une fois un test effectué.
3
Renfield Messages postés 17287 Date d'inscription mercredi 2 janvier 2002 Statut Modérateur Dernière intervention 27 septembre 2021 71
28 mai 2007 à 10:44
voir si dans Projet > References aucune erreur ne t'est remontée...

voir la version d'ADO installée sur le serveur

Renfield
Admin CodeS-SourceS- MVP Visual Basic
0
cs_reyman Messages postés 148 Date d'inscription mercredi 20 février 2002 Statut Membre Dernière intervention 5 juin 2007
28 mai 2007 à 13:56
Bingo
C'etait bien le MDAC qui posait problème.
0