Pb avec la recherce d'une donnée dans une base oracle

Signaler
Messages postés
2
Date d'inscription
vendredi 25 mai 2007
Statut
Membre
Dernière intervention
25 mai 2007
-
Messages postés
4720
Date d'inscription
dimanche 26 février 2006
Statut
Modérateur
Dernière intervention
31 juillet 2021
-
je travaille avec delphi 7 et oracle 9i 
 voila j'ai une fentre d'acces cad qu'il faux introduire le mot de pass et le nom de l'utilisateur
je veux effectuer une recherche dans la table 'acces' qui a comme attribut 'util' et 'mot_passe'

g mis se code mais sa ne marche pas et sa me blok et je ne peu avancé dans mon application

le code 
adotable1.Active:=true;
adotable1.First;
if adotable1.locate('util;mot_pass',vararrayof(['''+eutil.text+''','''+emot_pass.text+''']),[]) then


begin


fichier1.Enabled:=true;
cons1.Enabled:=true;
edition1.Enabled:=true;
statistique1.Enabled:=true;


lnom_c.Visible:=false;
label1.Visible:=false;
Eutil.Visible:=false;
Emot_pass.Visible:=false;
lutilisateur.Visible:=false;
lmot_pass.Visible:=false;
bok.Visible:=false;
label2.Visible:=true;
end;
else
showmessage('le nom utilisateur n''existe pas');

1 réponse

Messages postés
4720
Date d'inscription
dimanche 26 février 2006
Statut
Modérateur
Dernière intervention
31 juillet 2021
14
adotable1.Active:=false;


adotable1.Active:=true;
// adotable1.First;  // inutile
if adotable1.locate('util;mot_pass',vararrayof(['''+eutil.text+''','''+emot_pass.text+''']),[])

est-ce que la connexion à la base fonctionne ?
est-ce que le locate marche ?

cantador