Serveur Service Windows

Signaler
Messages postés
41
Date d'inscription
lundi 12 février 2007
Statut
Membre
Dernière intervention
2 juin 2010
-
Messages postés
41
Date d'inscription
lundi 12 février 2007
Statut
Membre
Dernière intervention
2 juin 2010
-
Bonjour,

Je dois fournir un serveur qui tourne constament sur une machine meme si aucun utilisateur n'est loggé. C'est pourquoi je fais un Serveur multithread en Service Windows. Cependant, j'ai un gros problème, lorsque je lance mon serveur dans une forme tout va bien, ca marche parfaitement, tandis que des que je le met dans un service windows et que je lance le service, aucune réponse n'est envoyée par le serveur (je peux quand même me connecter sur le serveur, ce qui est assez étrange).

J'aimerais savoir si il y as un moyen de résoudre ce problème, merci de votre aide.

3 réponses

Messages postés
427
Date d'inscription
mercredi 1 octobre 2003
Statut
Membre
Dernière intervention
29 janvier 2008
1
Salut, ton probleme reste assez vague.

Tu as mis des enregistrements dans le journal event afin de savoir ou ce situe ton probleme ? ou bien tu as essayé d'attacher le process de ton service pour le débuggé pas a pas ?

Bonne journée

++
Messages postés
41
Date d'inscription
lundi 12 février 2007
Statut
Membre
Dernière intervention
2 juin 2010

Non je n'ai pas fait ca car je sais pas comment le faire. Je vais donner un exemple:

Si j'envoie REQUEST,FILELIST a mon fichier le serveur doit me renvoyer la liste de fichier qui se trouve dans un dossier,
lorsque je me connect au serveur via un client tcp basique, la connexion s'effectue mais le problème c'est que lorsque j'envoie la commande rien ne se passe, il ne me renvoie rien... alors que si je met le serveur dans une form normal (un .exe) cela marche tres bien
Messages postés
41
Date d'inscription
lundi 12 février 2007
Statut
Membre
Dernière intervention
2 juin 2010

Si j'envoie REQUEST,FILELIST a mon serveur pardon