Framework 1.1 vers 2.0

Résolu
Signaler
Messages postés
107
Date d'inscription
lundi 25 octobre 2004
Statut
Membre
Dernière intervention
16 décembre 2010
-
Messages postés
7741
Date d'inscription
mercredi 1 septembre 2004
Statut
Membre
Dernière intervention
24 septembre 2014
-
Bonjour,
j'ai une application qui tourne dans l'entreprise fonctionnant avec le framework 1.1. je voulais passer au 2.0 (visual studio 2005). Est ce que mon application tournera toujours ?
Merci par avance !

5 réponses

Messages postés
7741
Date d'inscription
mercredi 1 septembre 2004
Statut
Membre
Dernière intervention
24 septembre 2014
41
Le Framework .Net 2.0 n'inclu pas le Framework .Net 1.1, j'en ai fait l'expérience la semaine dernière avec l'installation d'un soft développé sous VB2003, qui m'a exiger l'installation du Framework .Net 1.1 alors que le 2.0 et le 3.0  étaient déjà installés sur la machine.

Par contre, toutes les fonctions du .Net 1.1 sont reprises dans le 2.0. Donc dès l'overture du projet VB2003 sous VB2005, l'assistant de convertion sera lancé et le projet sera mis a jours vers VB2005. Attention, ce sera désormais un projet VB2005 exisgeant le Framework 2.0 pour fonctionner. Il te faudra d'ailleurs recréer l'executable, éventuellement les packs de déploiement, ....

---- Sevyc64  (alias Casy) ----<hr size="2" width="100%" /># LE PARTAGE EST NOTRE FORCE #
Messages postés
3172
Date d'inscription
dimanche 15 février 2004
Statut
Membre
Dernière intervention
9 avril 2017
35
Salut,

Le Framework 2 inclus le Framwork 1. Tu n'auras donc aucuns problèmes.
En ouvrant un projet .net1 avec vs2005, un assistant fera la mise à jour.





__________
 Kenji
Messages postés
107
Date d'inscription
lundi 25 octobre 2004
Statut
Membre
Dernière intervention
16 décembre 2010

Génial ! Merci bcp !
Messages postés
107
Date d'inscription
lundi 25 octobre 2004
Statut
Membre
Dernière intervention
16 décembre 2010

Merci bien !
Bon eh bien je ne vais pas changer de version car ca va me faire changer de framework sur chaque poste ! (très pratique ...) C'est pas très bein pensé leur changeùent de version !
Messages postés
7741
Date d'inscription
mercredi 1 septembre 2004
Statut
Membre
Dernière intervention
24 septembre 2014
41
il te faudrait vérifier sur chaque poste, mais il est fort possible que le Framework 2.0 ait été installé lors de la mise à jour automatique de XP (si elle est activée).

J'ai déjà rencontrer plusieurs machines ou il été présent alors que l'on m'a prétendu ne pas avoir souvenir de l'avoir installé.

---- Sevyc64  (alias Casy) ----
<hr width="100%" size="2" />
# LE PARTAGE EST NOTRE FORCE #