Error __declspec(dllimport) lié STL ?? [Résolu]

Signaler
Messages postés
286
Date d'inscription
dimanche 27 novembre 2005
Statut
Membre
Dernière intervention
27 décembre 2009
-
Messages postés
286
Date d'inscription
dimanche 27 novembre 2005
Statut
Membre
Dernière intervention
27 décembre 2009
-
bonjour tout le monde,

alors voilà à la génération de mon projet, étape édition de liens, j'ai une tonne de
error LNK2001: symbole externe non résolu "__declspec(dllimport) public: __thiscall std::basic_string<char,struct std::char_traits<char>,class std::allocator<char> >::~basic_string<char,struct std::char_traits<char>,class std::allocator<char> >(void)" (__imp_??1?$basic_string@DU?$char_traits@D@std@@V?$allocator@D@2@@std@@QAE@XZ)
jusqu'à (dllimport) c'est à peu près tout le temps ce texte et ensuite ca varie un peu mais généralement ça contient les mots std, string et autres <>. Mon "maître de stage" avait l'air de dire que ça serait un problème au niveau de la STL qui devrait normalement se charger en standard pour ce projet.

jusqu'à maintenant les problèmes de "symbole externe non résolu" s'étaient résolus grâce à des ajouts de lib supplémentaires. sauf que là je vois pas trop quoi rajouter. ça me touche des fonctions que je n'ai pas programmé moi même.

quelqu'un a une idée ?

merci d'avance

Loki

1 réponse

Messages postés
286
Date d'inscription
dimanche 27 novembre 2005
Statut
Membre
Dernière intervention
27 décembre 2009
2
bon en fait j'ai trouvé, y avait des lib qui était bloquées volontairement par Visual, je les ai virées et ca roule

Loki