Accent dans un XML [Résolu]

cs_Burnside 1130 Messages postés mercredi 28 août 2002Date d'inscription 27 août 2013 Dernière intervention - 21 avril 2007 à 11:05 - Dernière réponse : cs_Girou 1204 Messages postés lundi 10 mars 2003Date d'inscription 23 juillet 2009 Dernière intervention
- 23 avril 2007 à 09:35
Bonjour,

Je n'arrive pas à afficher les accents dans mon module de news qui load un xml.

Code flash :
xmlNews = new XML();
xmlNews.onLoad = affichageNews;
xmlNews.load("news.xml");
function affichageNews() {
    txt = xmlNews.firstChild.toString();
}

Code xml :

<NEWS>
    Présentation: | le 21-04-07
Première réunion de la troupe.

    [mailto:webmaster@theatreattitude.be Burnside]

    --------------------------

</NEWS>
il m'affiche des carrés.

Ensuite j'ai ajouté au début du code xml :
<?xml version ="1.0" encoding="iso-8859-1"?>
<?xml version="1.0" encoding="UFT-8"?>

là il ne charge plus le xml.

Bien à vous.
Burnside.

..:: Enjoy living in hell ::..
http://www.art-line.be
Afficher la suite 

Votre réponse

3 réponses

Meilleure réponse
cs_Burnside 1130 Messages postés mercredi 28 août 2002Date d'inscription 27 août 2013 Dernière intervention - 21 avril 2007 à 11:13
3
Merci
Re,

J'ai trouvé : system.useCodepage = true;

Désolé du post inutile.

..:: Enjoy living in hell ::..
http://www.art-line.be

Merci cs_Burnside 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 119 internautes ce mois-ci

Commenter la réponse de cs_Burnside
cs_alise 2203 Messages postés lundi 12 juillet 2004Date d'inscription 26 janvier 2010 Dernière intervention - 21 avril 2007 à 19:38
0
Merci
Non Burnside, ton post n'est pas inutile, "system.useCodepage = true;" ne s'utilise plus depuis MX 2004 !

Alise
from FlashForum-oi.info
Commenter la réponse de cs_alise
cs_Girou 1204 Messages postés lundi 10 mars 2003Date d'inscription 23 juillet 2009 Dernière intervention - 23 avril 2007 à 09:35
0
Merci
Salut Burnside,
et salut Alize aussi !!!

Je ne savais pas que system.useCodepage = true était devenu obsolète....

Burnside, ajouter <?xml version="1.0" encoding="UFT-8"?>
 au début du fichier spécifie son format, mais tu dois bien vérifier d'avoir enregistré le fichier sous ce format.

Essaye en réenregistrant ton fichier via notepad -> enregistré sous et choisir le format UTF-8

@+
Commenter la réponse de cs_Girou

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.