Problème encodage, accent

Signaler
Messages postés
34
Date d'inscription
lundi 15 janvier 2007
Statut
Membre
Dernière intervention
8 octobre 2009
-
Messages postés
96
Date d'inscription
mardi 9 janvier 2007
Statut
Membre
Dernière intervention
18 avril 2007
-
Bonjour, voici mon code:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<?
include("../librairie/connection.php");

$xml='<?xml version="1.0" encoding="UTF-8" ?>';
$xml.='';

$res_evenement=mysql_query("Select * From evenement");
while($row_evenement=mysql_fetch_assoc($res_evenement))
    {
    $xml.='';
    $dossier = opendir("largeimages/");
        while ($Fichier = readdir($dossier))
        {
            if ($Fichier != "." && $Fichier != ".." && substr($Fichier,0,strrpos($Fichier, "_"))=="evenement".$row_evenement[NUM_EVENEMENT])
                {
                $xml.='';
                }
        }
        $xml.='';
    }
$xml.='

';
$fp = fopen("albums.xml", "w");fwrite($fp,$xml);fclose($fp);
?>

</head>.........

le problème est que les caractères ayant de accent sont absent dans le fichier xml quelqu'un peut maider svp ??

2 réponses

Messages postés
1980
Date d'inscription
dimanche 20 février 2005
Statut
Membre
Dernière intervention
24 septembre 2012
5
Salut,

essaie un utf8_encode() sur tes variables avant de les afficher

à+
Messages postés
96
Date d'inscription
mardi 9 janvier 2007
Statut
Membre
Dernière intervention
18 avril 2007

Bonsoir,
essaies avec ma source pour ne pas avoir de problèmes de charset http://www.phpcs.com/code.aspx?ID=42236

Cordialement,
Kdecherf