Problème avec la commande insert du table adapter [Résolu]

Messages postés
2
Date d'inscription
mercredi 4 avril 2007
Statut
Membre
Dernière intervention
4 avril 2007
- - Dernière réponse : spiralilas
Messages postés
2
Date d'inscription
mercredi 4 avril 2007
Statut
Membre
Dernière intervention
4 avril 2007
- 4 avril 2007 à 06:27
Bonjour!

Je n'arrive pas à générer les commandes insert, delete et select sur un tableadapter en particulier (j'obtiens une erreur disant que insert is not a member of le tableadapter en question). (Les autres tableadapter fonctionnent bien.) Pourtant, la commande se trouve belle et bien dans le table adapter du fichier dataset.xsd, et le update existe. Refaire la configuration avec le wizard ne fonctionne pas (eh oui! j'ai cliqué generate insert, update and delete dans les paramètre avancés), même s'il me dit que le insert a été généré. J'ai vérifié l'orthographe de l'appel à la commande insert et c'est correct. Quelqu'un a une idée pour corriger le problème? Faut-il aller déclarer manuellement la commande insert dans les fichiers cachés (j'ai vérifié, elle ne s'y trouve pas)? J'utilise vb 2005 professionnel, connecté à Access.

Merci d'avance!
Afficher la suite 

1 réponse

Meilleure réponse
Messages postés
2
Date d'inscription
mercredi 4 avril 2007
Statut
Membre
Dernière intervention
4 avril 2007
3
Merci
J'ai finalement trouvé. Étrange comme la nuit porte conseil! 2 minutes de sommeil et ça y est! GenerateDBDirectMethods était à False, alors qu'il fallait qu'il soit à True.

Dire « Merci » 3

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 133 internautes nous ont dit merci ce mois-ci

Commenter la réponse de spiralilas