Excel VBA Insertion formule dans Cells [Résolu]

Signaler
Messages postés
143
Date d'inscription
dimanche 28 septembre 2003
Statut
Membre
Dernière intervention
6 septembre 2011
-
Messages postés
3877
Date d'inscription
mardi 19 mars 2002
Statut
Membre
Dernière intervention
23 août 2018
-
Hello Les modérateurs



Programme VBA (Excel)




<?xml:namespace prefix o ns "urn:schemas-microsoft-com:office:office" /??>
 






Un petit problème. Insertion  d’une formule dans une Cells, là voila



SI(G724"";"";G724/C724),



Un jour de réfection mais toujours pas de solution. Le problème est chr(34) ou "



Avez-vous une solution.




 






Merci pour votre réponse



A plus sur VBFrance.com
42wawa42

8 réponses

Messages postés
143
Date d'inscription
dimanche 28 septembre 2003
Statut
Membre
Dernière intervention
6 septembre 2011

Hello Les modérateurs
 
Programme VBA (Excel)
 
Merci pour votre réponse tous est juste.
 Il y a des programmeurs comme mois qui font des grands trous, et qui ne trouve toujours pas de réponse a des petits problèmes.
 
A plus sur VBFrance.com
 42wawa42
Messages postés
3877
Date d'inscription
mardi 19 mars 2002
Statut
Membre
Dernière intervention
23 août 2018
18
Si tu utilises FORMULA, il faut que ta formule soit écrite en anglais avec virgule comme séparateur

Range("A1").Formula = "=IF(G724="""","""",G724/C724)"

et dans ce cas particulier, il faut doubler les apostrophes

Si tu veux utiliser les formules françaises, il faut utiliser FORMULALOCAL
Mais le principe des apostrophes demeure le même.

MPi
Messages postés
2237
Date d'inscription
lundi 29 mai 2006
Statut
Membre
Dernière intervention
29 mai 2008
10
Salut range("A1").Formula = "=SI(G724="";"";G724/C724)"



 Drikce 06

Si la réponse vous convient: Réponse acceptée. Si la réponse vous convient pas:
Messages postés
143
Date d'inscription
dimanche 28 septembre 2003
Statut
Membre
Dernière intervention
6 septembre 2011

Hello Les modérateurs



Programme VBA (Excel)




<?xml:namespace prefix o ns "urn:schemas-microsoft-com:office:office" /??>
 






Merci pour votre réponse.





Apres

   l’exécution du programme j’ai la formule suivante dans mon application





SI(G724";";G724/C724),










la disparition des caractères chr(34) deux fois.






 






Merci pour votre réponse



A plus sur VBFrance.com





42wawa42









 
Messages postés
2237
Date d'inscription
lundi 29 mai 2006
Statut
Membre
Dernière intervention
29 mai 2008
10
Salut range("A1").Formula = "=SI(G724="";"";G724/C724)"




 Drikce 06

Si la réponse vous convient: Réponse acceptée. Si la réponse vous convient pas:
Messages postés
143
Date d'inscription
dimanche 28 septembre 2003
Statut
Membre
Dernière intervention
6 septembre 2011

Hello Les modérateurs



Programme VBA (Excel)




<?xml:namespace prefix o ns "urn:schemas-microsoft-com:office:office" /??>









SVP voir ma première réponse il manque quelque chose dans la formule.

"=SI(G724="";"";G724/C724)"

"=SI(G724=";";G724/C724)"




 







 

Merci pour votre réponse

A plus sur VBFrance.com



42wawa42
Messages postés
2237
Date d'inscription
lundi 29 mai 2006
Statut
Membre
Dernière intervention
29 mai 2008
10
Il faut doubler les ""

"=SI(G724="""";"""";G724/C724)"

 Drikce 06

Si la réponse vous convient: Réponse acceptée. Si la réponse vous convient pas:
Messages postés
2237
Date d'inscription
lundi 29 mai 2006
Statut
Membre
Dernière intervention
29 mai 2008
10
J'ai peut être mis beaucoup de "!

 Drikce 06

Si la réponse vous convient: Réponse acceptée. Si la réponse vous convient pas: