[ADO.NET] Prob connexion Base de données EasyPHP

Résolu
cs_cucrapock Messages postés 13 Date d'inscription jeudi 22 mars 2007 Statut Membre Dernière intervention 3 avril 2008 - 22 mars 2007 à 14:54
cs_cucrapock Messages postés 13 Date d'inscription jeudi 22 mars 2007 Statut Membre Dernière intervention 3 avril 2008 - 26 mars 2007 à 12:14
Bonjour,

j'ai récemment crée une petite base de données avec easyPHP. Je
voudrais la manipulé avec un petit programme en VB (en utilisant la
bibliothèque ADO.NET) mais j'ai des problèmes pour me connecter.

Je démarre mon serveur Mysql sur mon ordi et voila le code que j'utilise (ma base s'apelle adesms) :

Public Sub ouverture()

Dim state As Integer

Dim connection As New SqlConnection("Data Source=localhost;Initial Catalog=adesms;Integrated Security=true")

connection.Open()

End Sub

Là il plante systématiquement au niveau de la commande
connection.Open et il me répond que le serveur n'existe pas ou que
l'accès est refusé. J'ai essayé plein de solutions comme mettre
Integrated Security à false et rentrer un mot de passe et un login
valides ou encore remplacer localhost par 127.0.0.1/mysql/ (adresse à
partir de laquelle on peut atteindre la base sur un navigateur).

Si quelqun pouvait m'aider ce serait vraiment sympa.

D'avance merci

3 réponses

cs_Jack Messages postés 14006 Date d'inscription samedi 29 décembre 2001 Statut Modérateur Dernière intervention 28 août 2015 79
22 mars 2007 à 18:04
Salut
Jette un oeil sur les solutions de ce site, peut-être trouveras-tu ton bonheur --> http://www.connectionstrings.com/

Vala
Jack, MVP VB
NB : Je ne répondrai pas aux messages privés

Champion du monde de boule de cristal - 2005
Le savoir est la seule matière qui s'accroit quand on la partage (Socrate)
3
cs_Jack Messages postés 14006 Date d'inscription samedi 29 décembre 2001 Statut Modérateur Dernière intervention 28 août 2015 79
22 mars 2007 à 18:04
PS : MySQL utilise un driver ODBC.
L'as-tu installé ?
3
cs_cucrapock Messages postés 13 Date d'inscription jeudi 22 mars 2007 Statut Membre Dernière intervention 3 avril 2008
26 mars 2007 à 12:14
Bonjour,

merci beaucoup pour le tuyau. Il s'agissait d'un problème de connctionString.
0
Rejoignez-nous