Base de donnée, Ajout d'enregistrement! (HELP!!!)

Signaler
Messages postés
24
Date d'inscription
samedi 7 juin 2003
Statut
Membre
Dernière intervention
29 octobre 2007
-
Messages postés
47
Date d'inscription
jeudi 6 février 2003
Statut
Membre
Dernière intervention
22 mars 2006
-
Mon problème c'est que dans ma page ASP j'ajoute des enregistrements dans une table qui s'apelle "Messages", dans laquelle est stocké mes messages pour un forum...
Mais a tout bout-de-champs, j'ai une erreur qui se produit que sur mon serveur distant:

Error Type:
Microsoft JET Database Engine (0x80040E14)
Syntax error (missing operator) in query expression ''Je suis au coteaux pour le moment...
Mais études d'info l'année prochaine au CPLN...
Bon j'ai redoublé pr fair un passage en MO...
C'est ma passion dc normal! ;-)
A+''.

Je met aussi un extrait du code d'ajout:
If Action "Add" and Er True then
Response.Redirect "NewMessage.asp?ErrAdd=True&Cat=" & TCat & "&Pseudo=" & TPseudo & "&Email=" & TEMail & "&Message=" & TMessage & "&Theme=" & TTheme
End IfIf Not Er True and Action "Add" then
TPseudo = DelHTML(Session("UserPseudo"))
TMessage = DelHTML(TMessage)
TEMail = DelHTML(Session("UserEMail"))
Set AdoConn = Server.CreateObject ("ADODB.Connection")
AdoConn.Provider = "Microsoft.Jet.OLEDB.4.0"
AdoConn.ConnectionString = "Data Source=" & Server.MapPath ("forum.mdb")
AdoConn.Open
AdoConn.Execute ("INSERT INTO Messages (Cat, Theme, Pseudo, Mail, MDate, MTime, Message) VALUES ('" & TCat & "','" & TTheme & "','" & Session("UserPseudo") & "','" & Session("UserEMail") & "','" & CDate(Date) & "','" & CTime(Time) & "','" & TMessage & "')")
AdoConn.Close
Set AdoConn = Nothing
Response.Redirect "ViewMessages.asp?Cat=" & TCat & "&Theme=" & TTheme
End If

Je comprend pas du tout ce qui se passe!!!!

Pr info dans ma table j'ai un champ auto ki s'apelle "Num"
Et les autres c'est "Cat", "Theme", "Pseudo", "Mail", "Message", "MTime", "MDate"

Si qqun peut m'aider, car c'est vraiment vraiment important!!
Si jamais l'adresse du forum c'est: http://www.rpn.ch/escote/athacker/forum/

Merci!!

1 réponse

Messages postés
47
Date d'inscription
jeudi 6 février 2003
Statut
Membre
Dernière intervention
22 mars 2006
2
Aparemment ta requete SQL est correcte, mais le serveur te dis que non : essaye de l afficher au lieu de l executer (remplace ton AdoConn.Execute par un Response.Write) et tu vera.

A tout les coups, tu as des guillemets qui traine dans la variable TMessage qui sont interpretes comme ouverture et/ou fermeture de string.