Problème avec les images d'une listview associées à un imagelist

Résolu
cs_fauve Messages postés 661 Date d'inscription vendredi 2 décembre 2005 Statut Membre Dernière intervention 23 mars 2011 - 9 févr. 2007 à 22:48
cs_fauve Messages postés 661 Date d'inscription vendredi 2 décembre 2005 Statut Membre Dernière intervention 23 mars 2011 - 9 févr. 2007 à 23:09
Salut,

       J'ai un petit problème, voilà j'ai une listview où j'affiche les périphériques connectées sur la machine et en fonction du type de périphériques on affiche une image dans la listview avec le nom du périphérique(comme sous l'explorateur de windows).
      
       Pour cela, j'ai mis toutes les images que j'ai besoin dans un imagelist. Le souci vient quand je veux redimensionner les images du imagelist. En effet, par défaut quand mon programme se lance la listview est en LargeIcon et un moment, je voudrais passser en Détails donc il faut diminuer la taille des images(logique ;-) )

Pour cela : J'utilise cette ligne de code avant de changer la facon d'afficher sur la listview:

ImageList1.ImageSize = New Size(32, 32)
ListView1.View = View.Details

Le problème c'est qu'une fois cà fait, plus aucune image n'apparait dans la listview.

Est ce que quelqu'un saurait comment régler le problème ??? Merci

2 réponses

cs_fauve Messages postés 661 Date d'inscription vendredi 2 décembre 2005 Statut Membre Dernière intervention 23 mars 2011 8
9 févr. 2007 à 23:09
Salut,

Merci de m'avoir m'aidé.

Mais j'ai trouvé la solution en faîte il faut créer 2 imagelist :

Un imagelist pour LargeIcon

et

Un deuxième pour les autres types d'affichages (tailles des images plus petites)

@+ et encore merci de m'avoir aidé.
3
Utilisateur anonyme
9 févr. 2007 à 22:58
Bonsoir,

As-tu pensé à passer ton ImageList à la propriété SmallImageList de ta ListView ?






__________
Kenji
0