Connexion à MySql via composant Tdatabase en c++builder : HELP !!! [Résolu]

steph12358 150 Messages postés jeudi 22 avril 2004Date d'inscription 10 décembre 2009 Dernière intervention - 29 janv. 2007 à 09:21 - Dernière réponse : steph12358 150 Messages postés jeudi 22 avril 2004Date d'inscription 10 décembre 2009 Dernière intervention
- 30 janv. 2007 à 17:16
    Bonjour

lorsque j'essaye de me connecter à une base MySQL avec c++ builder 5 au travers d'un composant AccèsBD de type database mon application affiche une boîte de dialogue demandant l'identificateur de l'utilisateur et le mot de passe (2 fois ?!! de suite). Si je me loggue "à la main" ça fonctionne...

Le problème est que j'essaye de spécifier ces infos à l'aide de la propriété Params
afin d'éviter à l'utilisateur final d'avoir à taper ces informations, comme ceci :
"
DATABASE=maquette
DSN=maquettesqlplus
SERVER=localhost
UID=root
"
Mais ça ne marche pas : j'ai toujours droit à la fenêtre de login et évidemment si je n'entre rien ...

Le projet maquette.exe a provoqué une classe d'exception EDBEngineError avec le message

"Erreur SQL générale.

{MySQL][ODBC 3.51 Driver]Access denied for user 'ODBC@localhost' (using password : NO)

Alias: maquettesqlplus'. Processus stoppé. Utilisez Pas-à-Pas ou Exécuter pour continuer.


PS : remarque: pas de mot de passe pour l'instant mais j'en aurais un à terme".
Je ne peux pas utiliser l'accès natif car odbc m'est imposé.

Quelqu'un sait-il comment faire ?

Merci
Afficher la suite 

3 réponses

Répondre au sujet
steph12358 150 Messages postés jeudi 22 avril 2004Date d'inscription 10 décembre 2009 Dernière intervention - 30 janv. 2007 à 17:16
+3
Utile
Salut tout le monde

Ca marche bien cette fois-ci
Voici un exemple des paramètres à inclure dans la propriété "Params" du contrôle TDatabase
pour passer les infos de login automatiquement et ne pas avoir la fenêtre de connexion...
Ne pas oublier de mettre la propriété "LoginPrompt" à "false"

DATABASE NAME=mabase
USER NAME=root
ODBC DSN=mabasesqlplus
OPEN MODE=READ/WRITE
BATCH COUNT=200
LANGDRIVER=
MAX ROWS=-1
SCHEMA CACHE DIR=
SCHEMA CACHE SIZE=8
SCHEMA CACHE TIME=-1
SQLPASSTHRU MODE=SHARED AUTOCOMMIT
SQLQRYMODE=
ENABLE SCHEMA CACHE=FALSE
ENABLE BCD=FALSE
ROWSET SIZE=20
BLOBS TO CACHE=64
BLOB SIZE=32

Dans le tas je me doute bien que tous les paramètres ne sont pas forcément requis mais ils peut être intéressant de creuser alors je les donne tous

J'espère que ça pourra aider quelqu'un...
Cette réponse vous a-t-elle aidé ?  
Commenter la réponse de steph12358
steph12358 150 Messages postés jeudi 22 avril 2004Date d'inscription 10 décembre 2009 Dernière intervention - 30 janv. 2007 à 09:53
0
Utile
Bonjour à tous

j'ai enfin trouvé les paramètres ODBC pour éviter la fenêtre de login

DRIVER=MySQL ODBC 3.51 Driver
SERVER=localhost
DATABASE=mabasededonnees
UID=identifiant
PWD=motdepasse
OPTION=3

pour ceux que ça peut aider voici ma référence :
http://www.phpfreaks.com/manuals/mysql/connectors.html#myodbc-examples-programming-vb

Atchaô
Commenter la réponse de steph12358
steph12358 150 Messages postés jeudi 22 avril 2004Date d'inscription 10 décembre 2009 Dernière intervention - 30 janv. 2007 à 10:59
0
Utile
Rebonjour

Ben non en fait, j'avais fait une erreur, marche toujours pô
toujours cette fichue boîte de dialogue

Si quelqu'un peut me venir en aide...
Commenter la réponse de steph12358

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.