Deployement ASP.net

Signaler
Messages postés
28
Date d'inscription
vendredi 17 mars 2006
Statut
Membre
Dernière intervention
14 août 2008
-
Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
-
Bonjour,

 Voila mon probleme, j'ai dévellopper un petit site en local, je l'ai déployer et maintenant j'ai une erreur quand j'essaye de l'ouvrir avec ie :

<li>Error Type:
Active Server Pages, ASP 0221 (0x80004005)
The specified 'page language="C#" masterpagefile="~/MasterPage.master" autoeventwireup="true" inherits="Default.aspx.cs, App_Web_uysociyz" title="Untitled Page" ' option is unknown or invalid.
/helpdesk/hdl/Default.asp, line 1
</li>Qqun peut m'aider ? merci

 

5 réponses

Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
28
Bonjour

tu essaies de faire de l'asp 3 (qui a bientot 10 ans) en mélangeant ASP.net (fichier .aspx) je te conseille d'utiliser Visual Web Developper qui est le dernier outil pour faire de l'asp.net est surtout qui est gratuit ! tu le trouveras sur le site de microsoft 

<hr />Cyril - MVS - MCP
Messages postés
28
Date d'inscription
vendredi 17 mars 2006
Statut
Membre
Dernière intervention
14 août 2008

heuuuuu :|

ha bon, j'utilise visual studio 2005, je crée un projet web, j'utilise un livre qui parle d'asp.net,
je sais meme pas ce que cest de l'asp 3 :|. Si tu te referes au nom de fichier .asp, c'était un .aspx uniquement renommer en .asp, je me demande d'ailleur si ce n'est pas ca qui pause probleme.

Si qqun a plus de détails a ce sujet, merci
Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
28
Pourquoi avoir renommé .aspx en .asp ?

.aspx = asp.net
.asp = asp3

asp.net est le successeur de asp3 mais en fait c'est plutot une nouvelle techno qui remplace l'autre tellement il y a de différence ...

<hr />Cyril - MVS - MCP
Messages postés
28
Date d'inscription
vendredi 17 mars 2006
Statut
Membre
Dernière intervention
14 août 2008

et bien cela est dut a un probleme du serveur sur lequelle je déploye:


lorsque je fait http://monserveur/default.aspx => page not found


mais si je fais htpp://monserveur/index.html ca  marche (le fichier html et le aspx étant dans le meme dossier)

bizarre quoi
Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
28
Tu as donc un problème d'installation d'asp.net sur le serveur, il faut surement le réinstaller en utilisant la commande aspnet_regiis -i

<hr />Cyril - MVS - MCP