Site gourmand en ressource processeur... [Résolu]

Signaler
Messages postés
26
Date d'inscription
mercredi 19 janvier 2005
Statut
Membre
Dernière intervention
14 avril 2010
-
Messages postés
26
Date d'inscription
mercredi 19 janvier 2005
Statut
Membre
Dernière intervention
14 avril 2010
-
Bonsoir à tous,

J'ai un petit soucis. J'ai réalisé un site en flash (anim principale qui appelle des swf externes), tout ce passe bien mais
en regardant ce que mon site "consommait" en ressource processeur, je
me suis aperçu qu'il prenait environ 60 % selon certaines anim!
(notament celle où j'ai une animation style "caroussel")

Comment remèdier à ca?
Si quelqu'un a une tite idée,merci d'avance,
Nico.

PS: j'ai1Go de ram et un proc 3GHz

3 réponses

Messages postés
1203
Date d'inscription
lundi 10 mars 2003
Statut
Membre
Dernière intervention
23 juillet 2009
2
Bonjour,

peut-être y a-t-il trop d'éléments graphiques affichés et en mouvement en même temps.
Souvent l'utilisation des alpha est très gourmand en ressource systeme.
Beaucoup d'élément graphiques affichés et non visiles (stocké hors de la zone visible de l'écran) -> rendre ces clips ou objets invisibles lorsqu'ils ne sont pas utilisés.

Si tu as de nombreux onEnterFrame() qui ne sont pas ou plus nécessaires -> les détruire, quitte a devoir les réafecter plus tard.

@+
Messages postés
26
Date d'inscription
mercredi 19 janvier 2005
Statut
Membre
Dernière intervention
14 avril 2010

    oui, effectivement, j'ai fais un peu de ménage, et ca va mieux...
Par contre, internet explorer le lit plus rapidement que firefox ou meme , que safari... étrange non?
Messages postés
26
Date d'inscription
mercredi 19 janvier 2005
Statut
Membre
Dernière intervention
14 avril 2010

    en tous cas merci de ta contribution Girou,