Flash envoi Email fonction Parse

Résolu
Signaler
Messages postés
3
Date d'inscription
mardi 18 octobre 2005
Statut
Membre
Dernière intervention
14 novembre 2006
-
Messages postés
3
Date d'inscription
mardi 18 octobre 2005
Statut
Membre
Dernière intervention
14 novembre 2006
-
Bonjour a tous,

Je suis désespéré si quelqu' un a une idee.
je cherche a envoier un resulta de formulaire en flash par mail, j'utilise la methode post et un fichier en php.

< loadVariablesNum ("mail.php", 0, "POST"); >

***************
Mail.php
***************
<?
function Parse($variable,$valeur) {
echo "&" . $variable . "=" . utf8_encode(urlencode($valeur));



if (($nom!="") && ($prenom!="") && ($Adr_Envoyeur!="") && ($phone!="") && ($mes!="") )
{
  $mailheaders = "From: Site Internet  \n";
  $Sujet = " Site \n\n";
  $msg = "$nom\n\n $prenom\n\n $Adr_Envoyeur\n\n $mes\n\n";
  $mail_OK=mail("[mailto:stevenC123@hotmail.com stevenC123@hotmail.com]", $Sujet, $msg, $mailheaders);
  Parse("envoi_reussi",$mail_OK);
  Parse("op_fin","1");
}
else
{
  Parse("var_manquante","1");
  Parse("op_fin","1");
}
?>
************************************************
Le probleme c que je recois un mail avec des info du type :

<TEXTFORMAT LEADING="2">szsz

</TEXTFORMAT>

et que mon anim flash ne fonctionne pas, il semblerait que la fonction Parse ne marche pas
les variables ne sont pas declarées.

si vous avez une idee.sur mon probleme  :-)

5 réponses

Messages postés
2203
Date d'inscription
lundi 12 juillet 2004
Statut
Membre
Dernière intervention
26 janvier 2010

Pourquoi tu t'em……, tu as des sources de formulaires qui marchent sur ce forum, en flash/php et avec des scripts
qui tiennent la route. Et ta fonction Parse ne marche pas. Fais une petite recherche et tu trouveras ton bohneur

Alise
from FlashForum-oi.info
Messages postés
3
Date d'inscription
mardi 18 octobre 2005
Statut
Membre
Dernière intervention
14 novembre 2006

Je sais mais c pas nom truc j'aime bien comprendre pourquoi sa marche pas.
j'ai essayer des scripts sa marche pas j'ai toujours ce probleme de lecture des mails.

Merci pour ta reponse!
Messages postés
13
Date d'inscription
lundi 13 novembre 2006
Statut
Membre
Dernière intervention
14 mars 2007

j'ai le meme probleme et je suis comme toi!
à partir d'un script php pour un formulaire en flash, l'email qui est envoyer sur le compte de mon choix a pour en tete:
     "@sd-5178.dedibox.fr">  "/TEXTFORMAT>"@sd-5178.dedibox.fr à moi

puis tout le corp de mon message qui est parfait (seulont si le client met les bon critére)
mais le probleme ces que je ne comprend pas pourquoi j'ai sa!
"@sd-5178.dedibox.fr">        "@sd-5178.dedibox.fr à moi
pour exemple mon formulaire ce trouve sur cette page a l'adresse [www.weblyne.fr www.weblyne.fr]
dans la section contactez moi (s'abstenir d'envoyer des messages de test je vous pries pour éviter d'inonder mon serveur mail)
merci à la vous les flasheurs.
                                                
("résumer son problème ces comprendre son problème")
Messages postés
2203
Date d'inscription
lundi 12 juillet 2004
Statut
Membre
Dernière intervention
26 janvier 2010

Pour pouvoir avoir l'email que l'on souhaite
lorsque la personne clique sur répondre, il est nécessaire de définir
les "headers" de la fonction mail() de PHP (ici les headers sont dans
la variable êntete) :


//......


$entete = "From: bal@tonFai.com\n";


$entete .= "X-Mailer: Société\n";


$entete .= "X-Auteur: tonNom\n";




Alise
from FlashForum-oi.info
Messages postés
3
Date d'inscription
mardi 18 octobre 2005
Statut
Membre
Dernière intervention
14 novembre 2006

salut à tous ,
Voila le problème est simple j'utilise un script d'envoi de contact type email (reference client etc..), je le teste sur une appli flash simple (uniquement le formulaire et le script) et sa marche très bien.
J'intégre mon script sur mon projet flash et j'ai le même probléme (voir post precedent).

Pour info les headers sont def.

Je sais pas d'ou viens le probleme mais je vais trouver.

Merci a vous.

hybris