Loadmovie et XML

fabouse
Messages postés
4
Date d'inscription
mercredi 8 décembre 2004
Statut
Membre
Dernière intervention
9 octobre 2008
- 1 nov. 2006 à 18:09
luK09
Messages postés
23
Date d'inscription
samedi 9 octobre 2004
Statut
Membre
Dernière intervention
3 novembre 2006
- 3 nov. 2006 à 18:55
Bonjour,

Je viens demandé de l'aide car je sèche complétement...

J'ai un fichier flash qui charge les données d'un fichier xml dans des champs texte. Quand je compile ce flash il fonctionne très bien.
Le problème est que lorsque je fais un loadMovie de ce premier swf qui charge le xml dans dans un second swf qui affiche un menu, à ce moment le premier swf (xml loader) ne m'affiche plus les données du xml.
Je pense qu'il s'agit d'un problème de ciblage mais même après lecture de tutoriaux sur le sujet je n'arrive pas à afficher mon texte dans le second swf.

Le but étant lorsque je clic sur le bouton "Le Concept" de menu.swf qui appèle concept.swf par loadmovie de charger le xml comme lorsque l'on lance "concept.swf seul.

Je vous fourni la source :La Source

Merci à ceux qui prendront le temps d'y jeter un oeil.
A+

3 réponses

luK09
Messages postés
23
Date d'inscription
samedi 9 octobre 2004
Statut
Membre
Dernière intervention
3 novembre 2006

2 nov. 2006 à 17:57
Bonjour,

ton problème peut venir d'erreur dans les niveaux ( ou nom d'occurence ).
Vérifis dans ton fichier "concept.fla" les niveaux, il est possible que tu es utilisé un "_root." inadécouate.
Il est préférable d'utiliser les "_parent." ou les "this." pour cibler un clip

Bon courage et bonne continuation

-[Flash quand tu nous tiens]-
0
fabouse
Messages postés
4
Date d'inscription
mercredi 8 décembre 2004
Statut
Membre
Dernière intervention
9 octobre 2008

3 nov. 2006 à 13:55
Merci pour ta réponse !
Effectivement il s'agissait d'un problème de niveau ... j'ai refait mon ciblage en virant tous les _root et cela fonctionne parfaitement.
Je crois que je vais banir les _root à l'avenir.
Merci encore ;)
0
luK09
Messages postés
23
Date d'inscription
samedi 9 octobre 2004
Statut
Membre
Dernière intervention
3 novembre 2006

3 nov. 2006 à 18:55
Je n'irai pas jusqu'à dire qu'il faut bannir les "_root" ^^
Ils sont par exemple pratique pour définir des variables qui sont utilisées souvent et à des niveaux différents.
Ils sont aussi indispensables pour un préchargement d'une animation qui serait racine d'un projet

PS: à l'avenir, laves tes dents avant de poster XD

-[Flash quand tu nous tiens]-
0