Problème avec les fonctions mkdir et copy

i_robot Messages postés 17 Date d'inscription dimanche 2 juillet 2006 Statut Membre Dernière intervention 8 décembre 2007 - 23 oct. 2006 à 19:58
i_robot Messages postés 17 Date d'inscription dimanche 2 juillet 2006 Statut Membre Dernière intervention 8 décembre 2007 - 28 oct. 2006 à 17:10
Salut,
j'ai un probleme avec les fonction mkdir et copy. je veut copier un copier un dossier et le rennomer selon le nom que le visiteur aura choisi.
Le repertoire se crée et les fichiers sont copier dans le nouveau dossier, mais le probleme est que lorsque je part voir les fichiers dans le nouveau dossier ca m'écrit une erreur 500 du serveur.
Quelqu'un pourait-il m'aider.

4 réponses

malalam Messages postés 10839 Date d'inscription lundi 24 février 2003 Statut Membre Dernière intervention 2 mars 2010 25
24 oct. 2006 à 10:11
Hello,

tu fais comment pour "aller les voir" ?
i_robot Messages postés 17 Date d'inscription dimanche 2 juillet 2006 Statut Membre Dernière intervention 8 décembre 2007
24 oct. 2006 à 22:25
je par a l'url de nouveau dossier créé
malalam Messages postés 10839 Date d'inscription lundi 24 février 2003 Statut Membre Dernière intervention 2 mars 2010 25
25 oct. 2006 à 14:07
Fais voir ton code (et ne reposte pas un nouvelle fois cette question, merci).
i_robot Messages postés 17 Date d'inscription dimanche 2 juillet 2006 Statut Membre Dernière intervention 8 décembre 2007
28 oct. 2006 à 17:10
En fait c'est pour un service de création de blogs, les gens s'inscrivent a la zone membre et ils ont leur blog.
Voici le code :


if(is_dir("$_SESSION['membre']")){
echo "Le nom de votre blog : $nomblog est déjà utilisé.";
}
else {
mkdir("blogs/".$_SESSION['membre']."", 0777);
mkdir("blogs/".$_SESSION['membre']."/admin", 0777);
mkdir("blogs/".$_SESSION['membre']."/includes", 0777);
mkdir("blogs/".$_SESSION['membre']."/admin/uploads", 0777);

copy('blogs/tstcblog/index.php', 'blogs/'.$_SESSION['pseudom'].'/index.php');
copy('blogs/tstcblog/emx_nav_right.css', 'blogs/'.$_SESSION['pseudom'].'/emx_nav_right.css');
copy('blogs/tstcblog/admin/maj.php', 'blogs/'.$_SESSION['pseudom'].'/admin/maj.php');
copy('blogs/tstcblog/admin/verifmaj.php', 'blogs/'.$_SESSION['pseudom'].'/admin/verifmaj.php');
copy('blogs/tstcblog/admin/news.php', 'blogs/'.$_SESSION['pseudom'].'/admin/verifnews.php');
copy('blogs/tstcblog/header.gif', 'blogs/'.$_SESSION['pseudom'].'/header.gif');
copy('blogs/tstcblog/admin/news.php', 'blogs/'.$_SESSION['pseudom'].'/admin/news.php');
copy('blogs/tstcblog/admin/add_page.php', 'blogs/'.$_SESSION['pseudom'].'/admin/add_page.php');
copy('blogs/tstcblog/admin/verif_add_page.php', 'blogs/'.$_SESSION['pseudom'].'/admin/verif_add_page.php');
}

le probleme est que lorsque je pars a l'adresse d'un des fichiers copier il une erreur 500

MERCI D'AVANCE.
Rejoignez-nous