Problème pour "casser" une requete Insert Into [Résolu]

Signaler
Messages postés
31
Date d'inscription
mercredi 10 mai 2006
Statut
Membre
Dernière intervention
20 juin 2007
-
Messages postés
31
Date d'inscription
mercredi 10 mai 2006
Statut
Membre
Dernière intervention
20 juin 2007
-
Bonjour!

J'ai un pti souci avec une requete sur une base de donnée mysql... Je dois remplir ma base avec toutes les valeurs des champs d'un formulaire, mais il y a tellemnt de données à rentrer dans ma base qu'elles ne peuvent pas toutes être mises sur une seule ligne... Comment dois-je "casser" ma requete pour que ça fonctionne? Voici un extrait du code que j'ai pour l'instant, mais ilne fonctionne pas correctement (à cause de la dernière ligne certainement). Merci.

connexBaseBienUtil.Execute "INSERT INTO bien " _
    & "(jour,mois,adresse,nom,prenom.......,annee) VALUES" _
    & "('" + Jour.Text + "','" + Mois.Text + "',..........'"+ Combo6.Text + "' _
    & "'" + Text(26).Text + "', .........................'" + Annee.Text + "')"
       

3 réponses

Messages postés
31
Date d'inscription
mercredi 10 mai 2006
Statut
Membre
Dernière intervention
20 juin 2007

Ok c bon ça marche!!!!! Le code est bon, en fait c'était bien des valeurs dans la bdd qui n'étaient pas les mêmes que les champs du formulaire....(chui pa blonde pr rien.... ) Merci pour tout!
Messages postés
7393
Date d'inscription
mercredi 23 avril 2003
Statut
Membre
Dernière intervention
6 avril 2012
56
Salut,

Lorsque tu dis il ne Fonctionne pas correctement, je suppose que le champs n'est pas inséré.

Es tu sur que le nombre de champs "(jour,mois,adresse,nom,prenom.......,annee) est bien égale au nombre de valeur .
Es tu sur que les type de valeur (champs) sont bien respectés lors de l'insertion.

Je pense que tu devrais nous fournir la requête entiere cela nous aiderait peu etre un peu plus

@+,   Ju£i?n
Messages postés
31
Date d'inscription
mercredi 10 mai 2006
Statut
Membre
Dernière intervention
20 juin 2007

Salut,
D'abord merci pour ta réponse. J'ai fait très attention à bien respexter les valeurs des champs et le nombre de valeurs par rapport au nombre de champs, donc normalement pas de problème de ce coté là. Je vais tout revérifier qd meme. Est-ce que le bug peut etre causé par les premiers guillemets de la dernière ligne d'après toi? (puisqu'ils n'auraient pas lieu d'être s'il n'y avait pas de retour à la ligne...) Mais je suis obligée de les mettre, sinon, ma ligne est considérée comme un commentaire....

Merci.