Tout mais aplicattions WinApi ne narche pas (ou pas correctement)

Signaler
Messages postés
15
Date d'inscription
mercredi 23 août 2006
Statut
Membre
Dernière intervention
20 avril 2008
-
Messages postés
212
Date d'inscription
dimanche 3 avril 2005
Statut
Membre
Dernière intervention
28 mai 2011
-
Hello  .

 
J'ai un souci avec mon system ...

 
Je suis sous Windows XP SP2, et j'ai un problème avec mais application Programmé en Api Win 32.

Tout les contrôles de mes fenêtres (boutons, champ d'éditions,
etc..) ne s'affichent pas, et encor moins si j'ajoute a mon programme
un fichier Manifest (qui ser à donné le style actuel de Win xp aux
applications).

 
Je vous signal que ce n'ai pas un problème de Programmation
et que le problème Vien de mon système, car tout ces applications
marchais bien avant, est marchent bien quand je les essaye sur un autre
ordi (avec Win xp sp2), donc le problème est sur mon pc.
 
Mais je ne vois pas où es le prob.
Merci pour votre genereuse aide.

3 réponses

Messages postés
402
Date d'inscription
mardi 1 mai 2001
Statut
Membre
Dernière intervention
15 août 2011

GetLastError() te retourne surement quelque chose non? t'as essayé en debug pour voir? rare sont ceux qui vérifient la valeur retourné par CreateWindow[Ex]() mais tu pourrais vérifier pour savoir si elle retourne NULL ou non et si c'est le cas, regarde GetLastError(), quelle valeur elle retourne ...

http://msdn.microsoft.com/library/default.asp?url=/library/en-us/debug/base/system_error_codes.asp

~(.:: NitRic ::.)~
Messages postés
15
Date d'inscription
mercredi 23 août 2006
Statut
Membre
Dernière intervention
20 avril 2008

Mais le problème n'ai pas dans le code source du (des)
programme(s), puisque j'ai remarqué qu'il marche bien sur un autre ordi, est
que ce n'ai pas le seul prog qui ne marche pas chez moi !
Messages postés
212
Date d'inscription
dimanche 3 avril 2005
Statut
Membre
Dernière intervention
28 mai 2011
2
t'as pas attrapé un virus par hasard?

<hr size="2" width="100%" />Trafic web gratuit!!!