Droits d'écriture sur base Access [Résolu]

Signaler
Messages postés
27
Date d'inscription
mardi 29 novembre 2005
Statut
Membre
Dernière intervention
29 mars 2008
-
Messages postés
27
Date d'inscription
mardi 29 novembre 2005
Statut
Membre
Dernière intervention
29 mars 2008
-
Bonjour à tous,

Désolé, ça doit être un problème  classique, mais impossible d'ouvrir une base access en lecture/ecriture via des pages ASP.Net c#

J'ai un fichier access placé dans un répertoire de mon répertoire Web.
Je travaille depuis VisualStudio en C# dans un projet ASP.Net.
Lorsque je fais une simple interrogation de la base pas de problème, ça fonctionne. La chaine de connexion est du type :
string strConnexion = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\\Inetpub\\wwwroot\\Stock\\base\\Stock.mdb";

Si je veux faire une ecriture sur la base j'utilise plutôt :
string strConnexion = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source=C:\\Inetpub\\wwwroot\\Stock\\base\\Stock.mdb; Mode=3";
mais ca plante :
Le moteur de la base de données Microsoft Jet ne peut pas ouvrir le fichier
'C:\Inetpub\wwwroot\Stock\base\Stock.mdb'. Il est déjà ouvert en mode
exclusif par un autre utilisateur, ou vous devez avoir l'autorisation de
visualiser ses données.

La base est configurée en mode partagé. J'ai les droits système sur le fichier mdb et sur le répertoire (R/W)

Je suis certain que c'est un problème au niveau de la configuration sécurité de IIS (méthodes d'authentification) et du fichier  web.config (je suis en ).
Si quelqu'un peut me filer un coup de main pour ça, ce serait sympa.... je suis un peu à la bourre !!

3 réponses

Messages postés
1642
Date d'inscription
samedi 6 novembre 2004
Statut
Modérateur
Dernière intervention
28 avril 2011
3
Salut,

Quand tu dis "J'ai les droits système sur le fichier mdb", tu parles de l'utilisateur windows nommé ASPNET ?
C'est à lui que tu dois donner les droits sur le fichier, car c'est lui qui va ouvrir ta base de données, pas l'utilisateur courant !

A++

<hr width="100%" size="2" />Nurgle(Antoine)
Messages postés
27
Date d'inscription
mardi 29 novembre 2005
Statut
Membre
Dernière intervention
29 mars 2008

Pardonnez ma grande incompétence.... en fait je suis un peu dérouté par la gestion "administrative" de Xp Pro...
La gestion "à l'utilisateur" se fait en décochant l'option "Utiliser le partage de fichiers simple" dans l'explorateur (cf: http://www.vulgarisation-informatique.com/droits-acces.php).
En mettant la droits à tout le monde sur mon fichier, ça marche.

C'est donc bien un pb d'accès fichier, merci Nurgle.
Messages postés
27
Date d'inscription
mardi 29 novembre 2005
Statut
Membre
Dernière intervention
29 mars 2008

Heuuu... je suis plus habitué aux gestions système Unx.... là, je fais simplement un clic droit > propriétés et je vérifie l'attribut "Lecture seule".

Pas suffisant je suppose mais je ne trouve pas d'outils qui me permet de définir les droits / utilisateur...

Au fait, j'ai oublié de dire, je suis tout en local sur mon PC ... je ne passe pas par réseau.