ListView N° de l'item sélectionné ? vb2005e [Résolu]

Messages postés
548
Date d'inscription
mercredi 28 juillet 2004
Dernière intervention
11 septembre 2013
- 23 sept. 2006 à 22:38 - Dernière réponse :
Messages postés
13368
Date d'inscription
lundi 13 décembre 2004
Dernière intervention
3 février 2018
- 24 sept. 2006 à 00:09
Bonsoir,

Je dois avoir les yeux vraiment crados :(
pas moyen de trouver le code qui me permet de récupérer le N° index de l'item sélectionné dans un ListView ?

merci de vos réponses

(je trouve le msdn vb2005 express un peu fouilli quand même)
Afficher la suite 

Votre réponse

6 réponses

Meilleure réponse
Messages postés
3181
Date d'inscription
dimanche 15 février 2004
Dernière intervention
9 avril 2017
23 sept. 2006 à 23:16
3
Merci
Parsque aucun item n'est séléctionner

Dim
idx
As

Integer

If
TaListView.SelectedIndices.Count > 0
Then
idx = TaListView.SelectedIndices(0)





Kenji

Merci Charles Racaud 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 92 internautes ce mois-ci

Commenter la réponse de Charles Racaud
Messages postés
3181
Date d'inscription
dimanche 15 février 2004
Dernière intervention
9 avril 2017
23 sept. 2006 à 23:08
0
Merci
http://www.vbfrance.com/infomsg_LISTVIEW-ITEM-SELECTIONNE-VB2005_817638.aspx#5




Salut,

TaListView.SelectedIndices te renvoie une  collection d'index des items séléctionners, si tu travaille avec une simple séléction :
TaListView.SelectedIndices(0)



Kenji
Commenter la réponse de Charles Racaud
Messages postés
548
Date d'inscription
mercredi 28 juillet 2004
Dernière intervention
11 septembre 2013
23 sept. 2006 à 23:09
0
Merci
je précise aussi MultiSelect est à false

je souhaite simplement récupérer le n° de l'index sélectionné à la souris

merci
Commenter la réponse de vercomax
Messages postés
548
Date d'inscription
mercredi 28 juillet 2004
Dernière intervention
11 septembre 2013
23 sept. 2006 à 23:12
0
Merci
dim idx as integer

idx=TaListView.SelectedIndices(0) me retourne l'erreur:




InvalidArgument=La valeur '0' n'est pas valide pour 'index'.
Nom du paramètre : index

je pige pas

merci
Commenter la réponse de vercomax
Messages postés
548
Date d'inscription
mercredi 28 juillet 2004
Dernière intervention
11 septembre 2013
23 sept. 2006 à 23:20
0
Merci
IMPECABLE !

merci beaucoup !

je m'en rappellerai de celle-là   :)
Commenter la réponse de vercomax
Messages postés
13368
Date d'inscription
lundi 13 décembre 2004
Dernière intervention
3 février 2018
24 sept. 2006 à 00:09
0
Merci
rapelle toi également de ne pas poster de doublons, çà devient pénible!
merci

<hr size="2" width="100%" />Prenez un instant pour répondre à ce sondage svp
Commenter la réponse de PCPT

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.