Boucle while et attachMovie !!!

Résolu
Messages postés
22
Date d'inscription
vendredi 27 mai 2005
Statut
Membre
Dernière intervention
20 juin 2007
-
Messages postés
22
Date d'inscription
vendredi 27 mai 2005
Statut
Membre
Dernière intervention
20 juin 2007
-
Bonjour à tous!!!

Alors vala, je vous explique le probleme:

*j'ai sur mon image des petits clips "V1" et "V2"
*dans les clips "V1"et "V2" il y a les clips "ANB" et "AC"
*dans la bibliotheque il y a le clips "NB" et "C" (esportés vers Action Script et chargés dans la premiere image)
>j'ai donc (essayé >ça marche po) de créer une boucle while pour charger les clips "NB" et "C" dans les clips de la scnene "ANB" et "AC"

la variable x fonctionne (vérifié avec le trace(x)) mais on dirait quelle ne permet pas d'afficher le chemin des clips "containers"
... je désespère ... aider moi SVP!!!

stop();
i = 1;
while (i<3) {
    x = "_root.V"+i;
    trace(x);
    trace(i);
    x.ANB.attachMovie("NB", "NB1", i);
    x.AC.attachMovie("C", "C1", i);
    i++;
}

2 réponses

Messages postés
759
Date d'inscription
mercredi 11 décembre 2002
Statut
Membre
Dernière intervention
12 novembre 2008

Bonjour
x c'est une variable pas un clip pour remédier a ca :
    _root[x].ANB.attachMovie("NB", "NB1", i);
    _root[x].AC.attachMovie("C", "C1", i);

<hr />http://www.carton.c.la
Messages postés
22
Date d'inscription
vendredi 27 mai 2005
Statut
Membre
Dernière intervention
20 juin 2007

OUHHHHAAAA ... (ça marche, probleme résolut)

merci "shubenka" ça marche nikel