Les accents avec readfile("textfile.txt") [Résolu]

Radiohead4ever 71 Messages postés samedi 7 février 2004Date d'inscription 21 novembre 2006 Dernière intervention - 29 août 2006 à 05:13 - Dernière réponse : Radiohead4ever 71 Messages postés samedi 7 février 2004Date d'inscription 21 novembre 2006 Dernière intervention
- 29 août 2006 à 17:30
Avec la fonction readfile() je n'arrive pas à lire un fichier texte avec ses accents. Par exemple, un "é" s'affiche "é". J'ai pourtant spécifié charset dans le head de ma page : <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">.
Quelqu'un a une idée pourquoi? Quelqu'un m'a donné une piste, de m'informer sur htmlentities() mais je ne crois pas que ce soit ça. En tout cas, je ne suis pas arrivé à faire afficher mes accents.

[Black]Radio/Black[Red]Head/Red[Yellow]4/Yellow[Green]Ever/Green
Afficher la suite 

4 réponses

Répondre au sujet
malalam 10918 Messages postés lundi 24 février 2003Date d'inscription 2 mars 2010 Dernière intervention - 29 août 2006 à 09:53
+3
Utile
Hello,

le fichier a probablement été enregistré en utf-8.
Change donc l'encodage de ta page.
Cette réponse vous a-t-elle aidé ?  
Commenter la réponse de malalam
DiGhan 240 Messages postés samedi 21 février 2004Date d'inscription 3 juin 2010 Dernière intervention - 29 août 2006 à 14:17
0
Utile
Salut,

effectivement si le changement d'encodage ne fonctionne pas, c'est vers la fonction htmlentities que tu dois te tourner(au niveau de l'enregistrement des données). Cette fonction transforme en equivalent HTML tous les caractères spéciaux(& " ' > < é è ...).
Les deux solutions à essayer...
Commenter la réponse de DiGhan
malalam 10918 Messages postés lundi 24 février 2003Date d'inscription 2 mars 2010 Dernière intervention - 29 août 2006 à 14:47
0
Utile
Nan, ça : "é", ça ne sera pas tranformé correctement par htmlentities.
Non, dans ce cvas il faut un utf8_decode (), ou un urf8_encode () sur les chaînes affichées. A tester.
Commenter la réponse de malalam
Radiohead4ever 71 Messages postés samedi 7 février 2004Date d'inscription 21 novembre 2006 Dernière intervention - 29 août 2006 à 17:30
0
Utile
malalam avait raison, il suffisait  de changer l'enregistrement du fichier en IS0-8859-1 plutôt qu'en UTF-8 (par défaut). Merci à vous.

[Black]Radio/Black[Red]Head/Red[Yellow]4/Yellow[Green]Ever/Green
Commenter la réponse de Radiohead4ever

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.