Impossible d'héberger mon site !!!

laraignee12
Messages postés
13
Date d'inscription
jeudi 6 juillet 2006
Statut
Membre
Dernière intervention
25 août 2006
- 25 août 2006 à 11:35
jesusonline
Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Membre
Dernière intervention
13 octobre 2010
- 28 août 2006 à 10:47
J'ai hébergé mon site chez 1 and 1

J'ai créé mon site web en local d'abord avec Visual web developper 2005
J'utilise SQL 2000 car l'hébergeur, 1 and 1, ne possède que des bases de données SQL 2000

Mon site marche très bien sur mon PC mais dès que j'essaie de le mettre en ligne ça ne marche pas......

La connexion à la base de données n'a pas l'air de se faire....

Je vois ça quand je teste en local :

Une erreur s'est produite lors de l'établissement d'une connexion au serveur. Lors de la connexion à SQL Server 2005, cet échec peut être dû au fait que les paramètres par défaut de SQL Server n'autorisent pas les connexions à distance. (provider: Fournisseur TCP, error: 0 - Hôte inconnu.)

voici mon web.config

<connectionStrings>

<addname="
db174444914ConnectionString2"
connectionString="
Data Source=mssql06.1and1.fr,1433;User Id=****;Password=***;database=db174444914;"

providerName="
System.Data.SqlClient"
/></

connectionStrings>Et quand je teste directement sur le site ça écrit ça :

Runtime Error

Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.

Please help.....

1 réponse

jesusonline
Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Membre
Dernière intervention
13 octobre 2010
29
28 août 2006 à 10:47
Bonjour,

quand tu test en local c'est surement normal puisque 1&1 n'autorise peut etre pas qu'on se connecte à la base à distance mais seulement à partir de chez eux. Pour ce qui est de l'erreur que tu as sur le serveur, il faudrais pouvoir regarder le détail de l'erreur à partir de l'hebergeur. Demande leur s'ils peuvent te donner les détails de l'erreur ou met le CustomError à Off dans le web.config mais c'est trés peu recommandé !

<hr />Cyril - MVS - MCP
0