Cookies en .NET

Résolu
tymo1313
Messages postés
6
Date d'inscription
samedi 12 août 2006
Statut
Membre
Dernière intervention
6 septembre 2006
- 24 août 2006 à 13:51
tymo1313
Messages postés
6
Date d'inscription
samedi 12 août 2006
Statut
Membre
Dernière intervention
6 septembre 2006
- 24 août 2006 à 22:23
tymo
bonjour tt le monde,
j'ai un pti problème pr mon site .NET.
pr enregistrer des cookies dans le browser du client, je doit écrire une fonction dans le fic Global.asax.
mais pr cela, j'utilise des diréctives "using" au début du fic mais ça me génère des erreurs.
est ce qu'il y a qq1 qui pourrai m'aider?
merci

6 réponses

jesusonline
Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Membre
Dernière intervention
13 octobre 2010
29
24 août 2006 à 22:17
Voici la syntaxe exacte :

<% @ Import Namespace="System.Web" %>

il y avait un s de trop

<hr />Cyril - MVS - MCP
3
jesusonline
Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Membre
Dernière intervention
13 octobre 2010
29
24 août 2006 à 19:58
Bonjour,

t'utilises quelle langage ? quelle version de .net ? on peut voir le code ou tu écrit tes using ?

<hr />Cyril - MVS - MCP
0
tymo1313
Messages postés
6
Date d'inscription
samedi 12 août 2006
Statut
Membre
Dernière intervention
6 septembre 2006

24 août 2006 à 21:10
tymo
j'utilise le c# et le framework2.0
pour les diréctives using qui me posent des problème, je les mets dans le fichier Global.asax comme suit:


<%@
Application
Language="C#" %>


 



<



script



runat
="server">


using




System.Web.Security;             
//ligne posant un problème



using




System.Security.Principal;      
//ligne posant un problème












void
Application_Start(

object
sender,

EventArgs
e) {


// Code that runs on application startup

}










void
Application_End(

object
sender,

EventArgs
e) {


// Code that runs on application shutdown

}










void
Application_Error(

object
sender,

EventArgs
e) {


// Code that runs when an unhandled error occurs

}
............................
</script>

merci
0
jesusonline
Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Membre
Dernière intervention
13 octobre 2010
29
24 août 2006 à 21:38
bonjour

<%@ Imports namespace="System.Web" %> en dessous de <%@ Application %>

<hr />Cyril - MVS - MCP
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
tymo1313
Messages postés
6
Date d'inscription
samedi 12 août 2006
Statut
Membre
Dernière intervention
6 septembre 2006

24 août 2006 à 21:48
tymo
je l'ai essayé mais ça me génère une erreur du genre:  Validation(ASP.NET): Attribute 'Imports' is not a valid attribute of element 'Application'
et une autre erreur similaire qui dit: Validation(ASP.NET): Attribute 'namespace' is not a valid attribute of element 'Application'
0
tymo1313
Messages postés
6
Date d'inscription
samedi 12 août 2006
Statut
Membre
Dernière intervention
6 septembre 2006

24 août 2006 à 22:23
tymo
merci
ça marche maintenant
0