Quel plugin ils utilisent ? Et AS1 toujours valide ?

Résolu
Signaler
Messages postés
12
Date d'inscription
samedi 5 juin 2004
Statut
Membre
Dernière intervention
24 août 2006
-
Messages postés
12
Date d'inscription
samedi 5 juin 2004
Statut
Membre
Dernière intervention
24 août 2006
-
Bonjour,

Je ne sais pas dans quelle rubrique ecrire donc je poste dans celle qui a le plus d'activité. En fait j'ai des questions :

Premierement je creer un site en flash (entre autres) et je ne sais pas en quelle version il faut que je publie, mon but étant d'avoir un site visible par tous. Donc je me demande si quelqu'un avait des stats sur le plugin utilisé par ses visiteurs (surtout que la version 8 ou 9 est passée en mise à jour windows !). Donc si vous avez des stats ou un avis fondé, pourriez vous le partager ?

Deuxiemement, j'ai lu que la version 10 de flash ne serait surement plus compatible avec l'ActionScript 1 (intox ou info ????), quand est il du plugin v 10 ?

Ouais je sais AS 1 c'est fini depuis longtemps mais jusque la j'ai tester que le flash 4 et 5 donc se mettre à jour meme si c'est necessaire, c'est pas le plus rapide !

Merci, si vous me repondez et bon surf

4 réponses

Messages postés
2203
Date d'inscription
lundi 12 juillet 2004
Statut
Membre
Dernière intervention
26 janvier 2010

Bonjour [auteurdetail.aspx?ID=288493 gpwebmaster]

1/ Pour les statistiques, pas besoin de demander aux membres, il suffir de taper sur google "lecteur flash stat", et tu obtients ceci :
http://www.adobe.com/products/player_census/flashplayer/version_penetration.html
on ne peut demander mieux comme sources de renseignements.

2/ Si tu regardes les statistiques, tu t'apercevras que tu peux publier sans vraiment de problèmes en version 6 minimum, mais tout dépend aussi de ton contenu et de l'AS utilisé, si c'est de l'AS2, c'est la version 7 qui s'impose bien sûr si tu n'utiles pas les nouvelles fonctionnalités de la version 8 !

3/ Tu parles de la version 10 de Flash, alors que la 9 n'est pas encore commercialisée, donc si tu veux faire ton site en Flash 10, il te faudra encore attendre quelques années !

4/ D'autre part qui te dit que l'AS1 est fini ? Pas du tout, beaucoup développent encore en AS1, (d'ailleurs dans Flash 8, tu peux toujours travailler en AS1) le jour où tu auras fait le tour du bouquin de Moock "La référence" et que tu sauras utiliser AS1 comme lui, tu verras que tu peux faire pas mal de belles choses complexes.
Donc là encore tout dépend de ce que tu veux faire ! Et si tu veux te mettre à jour laisses tomber Flash 4, 5 et 6, et passes au minimum à MX 2004.

Alise
from FlashForum-oi.info
Messages postés
2203
Date d'inscription
lundi 12 juillet 2004
Statut
Membre
Dernière intervention
26 janvier 2010

Je sais que tu n'as pas dit que tu étais un crac en AS, mais simplement tu disais : "Ouais je sais AS 1 c'est fini depuis longtemps", non je suis pas d'accord là dessus, l'AS1 n'est pas fini, il y a des Flasheurs qui ne passeront jamais à AS2 ni à plus forte raison à AS3 !
Tout dépend vraiment de ce que tu veux faire, il y a les "mordus" de code qui vont balancer des lignes de code pour le plaisir, et d'autres qui se servir de l'API de flash pour faire la même chose.
Exemple, les filtres de Flash8, tu peux les appliquer soit avec du code, soit en te servant de l'onglet filtre.

Pour ce qui est du lecteur 10, sincèrement pourquoi ne serait-il plus compatible ? Le lecteur 8 lit bien du flash4.

Excuses "l'enflammement" !!!!

Alise
from FlashForum-oi.info
Messages postés
12
Date d'inscription
samedi 5 juin 2004
Statut
Membre
Dernière intervention
24 août 2006

Merci pour tes infos alise !

J'ai cru comprendre que tu t'étais un peu emflammé mais je crois que je me suis mal exprimé : je n'ai pas dit AS1 etait mort ni que j'étais un crac en AS, mais quand je poste de l'AS1 tout le monde me dis qu'il serait temps que je me mette à l'AS2 voir AS3. C'est pour ça !

 ("le jour où tu auras fait le tour du bouquin de Moock "La
référence" et que tu sauras utiliser AS1 comme lui, tu
verras que tu peux faire pas mal de belles choses complexes.") => tu vois tu t'es emflammé pour rien !

Pur ce qui est de flash 10, j'ai entendu parlé des projets, donc je demandais si quelqu'un savait si le player 10 serait toujours compatible avec AS1
("Tu parles de la version 10 de Flash, alors que la 9 n'est pas encore
commercialisée, donc si tu veux faire ton site en Flash 10, il
te faudra encore attendre quelques années !") => là encore !

Enfin merci encore
Messages postés
12
Date d'inscription
samedi 5 juin 2004
Statut
Membre
Dernière intervention
24 août 2006

Excuses très largement acceptées, à vrai dire t'avais pas à en faire y'a eu une mauvaise communication, c'est pas grave la prochaine fois je m'expliquerai plus clairement !

Je te remercie pour tes réponses et j'ai mis ton site dans mes favoris comme quoi ça n'a pas que du mauvais

Bonne journée et encore merci