Impossible de démarrer le Débogage

[Résolu]
Signaler
Messages postés
438
Date d'inscription
samedi 24 mai 2003
Statut
Membre
Dernière intervention
23 janvier 2011
-
Messages postés
438
Date d'inscription
samedi 24 mai 2003
Statut
Membre
Dernière intervention
23 janvier 2011
-
Depuis quelques temps il m'ai impossible dans un de mes projets de le lancer en mode débogage, je suis obliger d'éxécuter mon programme avec le fichier générer (.exe). Imaginer pour chercher les erreurs comment je m'amuse...
Bref, mes anciens et nouveaux projets, eux, s'éxécute parfaitement !
a mon avis cela vient de mon projet ! il m'affiche l'erreur dans la feuille de démarrage (SplashScreen1) sur cette ligne :



        Version.Text = System.String.Format(Version.Text, My.Application.Info.Version.Major, My.Application.Info.Version.Minor)



et m'affiche ce message :



Une erreur s'est produite lors de la création du formulaire. Pour plus d'informations, consultez Exception.InnerException. L'erreur est : Échec de la demande d'autorisation de type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.



Merci par avance ;)
Note : J'utilise VB.Net 2005

2 réponses

Messages postés
438
Date d'inscription
samedi 24 mai 2003
Statut
Membre
Dernière intervention
23 janvier 2011

Merci casy pour ta réponse ;)

j'ai fouinner un petit peu partout, dans la faq de microsoft j'ai rien trouver, alors j'ai continuer à fouinner et me suis dit que logiquement ca devait etre que dans les propriétés de mon applications, puis j'ai regarder dans les différents onglets ( Application, Compiler, Déboguer, etc...)

j'ai vu dans sécurité, FileIOPermission les paramétres été sur inclure et dans la colonnes inclus afficher un point d'exclamation jaune ! pourquoi ? je ne sais guére car je n'ai pas toucher à cette partie, bref

j'ai ensuite cliquer sur le bouton réinitialiser sans succés, et aprés j'ai cliquer sur le Radiobutton "il s'agit d'une application de confiance totale" (si j'ai pas confiance en mes applications lol, ou allons-nous :) )

et la NIKEL !

Merci quand même et bon week'end ;)
Messages postés
7741
Date d'inscription
mercredi 1 septembre 2004
Statut
Membre
Dernière intervention
24 septembre 2014
40
As-tu cherché dans la faq de microsoft, il me semble que c'est un problème que c'est un problème que j'ai déjà vu abordé.
Si je ne confond pas avec autre chose, il y a une petite manip à faire pour que ça redevienne normal.

Sevyc64  (alias Casy)
<hr size="2" width="100%" /># LE PARTAGE EST NOTRE FORCE #