Déploiement ActiveX en résau

Signaler
Messages postés
51
Date d'inscription
samedi 21 mai 2005
Statut
Membre
Dernière intervention
9 août 2006
-
Messages postés
31
Date d'inscription
lundi 9 août 2004
Statut
Membre
Dernière intervention
18 décembre 2006
-
Bonjour tout le monde,

Je travaille actuellement sur un projet informatique utilisant la technologie ActiveX,
Je programme sous VS.NET 2003, je voudrais pouvoir déployer l'ActiveX obtenu sur le réseau interne de l'entreprise à partir du serveur (2003 Server).

J'ai donc créé un répertoire pour mon ActiveX (dll) par le biais de IIS, j'ai essayé de l'enregistrer dans la base de registre en utilisant Le Prompte fournit avec VS.NET 2003, en faisant la manipulation suivante:

    - regasm MonActiveX.dll
    puis
    -GacUtil MonActiveX.dll (Commande qui n'a pas fonctionné ... mais j'ai constaté toutefois que l'enregistrement dans la base de registre à été réalisé)

Pour afficher mon ActiveX j'utilise une page HTML qui à la structure suivante:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<title>Projet Informatique</title>
</head>

<object id=Projet
  classid="CLSID:6G6769B-28BE-3398-8013-25591FAC5202"
codebase="http://Adresse/PROJET/MonActiveX.dll#MonActiveX.ControlMain">
</object>

Malgré plusieurs essais et reprise je n'arrive pas (plus) à accéder, à mon ActiveX, c'est-à-dire que la page s'affiche avec un mini carré blanc. Quelqu'un aurait-il déjà déployé un activeX ...?

Merci d'avance

5 réponses

Messages postés
51
Date d'inscription
samedi 21 mai 2005
Statut
Membre
Dernière intervention
9 août 2006

Après plusieurs essais j'ai trouvé la bonne solution enfin le bon code HTML, ainsi quand je suis sur un poste du réseau et que j'accède à la page j'ai un message qui me demande est ce que je désire installer l'activeX, (Problème l'éditeur est inconnu donc Windows ne veut pas l'installer (SP2 à mon avis)), toutefois quand j'essai d'accéder à la même page du serveur ou se trouve mon activeX j'ai droit à une page blanche avec le petit carré blanc...
D'où peut venir le problème?

Merci d'avance.

Je m'atèle à essayer de signer numériquement la dll.
Messages postés
4936
Date d'inscription
lundi 17 février 2003
Statut
Modérateur
Dernière intervention
14 février 2014
34
problème de sécurité...


essaye en mettant le site dans les sites de confiances.






Sébastien FERRAND
(

blog
)
Consultant Indépendant
[Microsoft MVP Visual C#]
Messages postés
51
Date d'inscription
samedi 21 mai 2005
Statut
Membre
Dernière intervention
9 août 2006

Merci pour ton idée, mais c'est déjà le cas, en tout cas sur le serveur.
Messages postés
51
Date d'inscription
samedi 21 mai 2005
Statut
Membre
Dernière intervention
9 août 2006

J'ai réussi à signer numériquement ma dll et pourtant windows continue à me donner le même message concernant l'éditeur (Ne peut installer l'activeX car ne peut vérifier l'éditeur). Quelqu'un aurrait la solution?

Merci d'avance
Messages postés
31
Date d'inscription
lundi 9 août 2004
Statut
Membre
Dernière intervention
18 décembre 2006

Samut, je travaille aussi sur un activex, savez vous comment on signe un composant activex ??? merci !