Etrange problème avec un loadMovie (Flash8)

Signaler
Messages postés
1
Date d'inscription
mercredi 24 mars 2004
Statut
Membre
Dernière intervention
8 août 2006
-
Messages postés
17
Date d'inscription
dimanche 21 mai 2006
Statut
Membre
Dernière intervention
29 août 2006
-
Bonjour tout le monde !


Alors voilà j'ai un comportement un peu étranger sur une appli Flash 8.


---------


J'ai mon anim principale.


Depuis l'anim principale je load un swf dans un conteneur "mainMc".


this.mainMc.loadMovie("catalogue-artistes.swf");


----------


Dans "catalogue-artistes.swf", j'ai un bouton qui load un swf dans un conteneur "videMc" sur l'anim principale.


this.boutonBtn.onRelease=function() {
 loadMovie("ficheartiste.swf", _root.videMc);
}


----------



Ce qui ne marche pas:


Ce qu'il ya de bizarre et étrange c'est que quand je teste mon anim principale depuis Flash. Tout tourne impeccable. Mon swf se charge bien dans "videMc". Tout fonctionne.


Maintenant quand je teste dans un navigateur (ie, firefox) le swf ne se charge pas dans mon videMc. Si je le teste dans le player, ca ne marche pas non plus.


---------



Ce que j'ai déjà essayé:


J'ai vérifié les chemins: ça à l'air d'être bon...


J'ai essayer de loader un jpeg: ça ne marche pas non plus...


J'ai tout repris avec un nouveau swf vide de tout AS (au cas où il y aurait un conflit avec un code qqe part). En créant juste un bouton et en faisant un load movie dessus: ca ne marche pas...


Quand je suis dans "ficheartiste.swf" et que je fais un loadMovie dans un clip contenu dans "ficheartiste.swf": ca marche...


Quand j'exporte je suis avec une option sécurité locale "Accès aux fichiers locaux uniquement"...


J'ai désactivé mon antivirus (on sait jamais): Ca marche pas...


J'ai vidé mon cache une bonne dizaine de fois: Toujours rien...


----------


Je commence à franchement tourner en rond...
C'est quand même très étrange. C'est pourtant pas la première fois que j'utilise un loadMovie, mais c'est bien la première fois que je vois un truc pareil!


J'ai peut êre la tête un peu trop dans le guidon, j'ai besoin d'un oeil neuf!
Tout aide sera grandement appreciée!


Merci.

1 réponse

Messages postés
17
Date d'inscription
dimanche 21 mai 2006
Statut
Membre
Dernière intervention
29 août 2006

le pb vient de ton browser