RunInstallerAttribute.Yes

Signaler
Messages postés
70
Date d'inscription
mercredi 16 juin 2004
Statut
Membre
Dernière intervention
14 septembre 2015
-
Messages postés
70
Date d'inscription
mercredi 16 juin 2004
Statut
Membre
Dernière intervention
14 septembre 2015
-
Bonjour à tous,
SVP j'essaye d'installer un service windows developpé sous c#.
J'obtiens le message lors de cette installation (avec "installutil")
"logfile = C:\MyAppli\bin\Debug\MyAppli.InstallLog
No public installers with the RunInstallerAttribute.Yes attribute could be found
 in the C:\MyAppli\bin\Debug\MyAppli.exe assembly.
Remove InstallState file because there are no installers.
"
SVP faire pour que réussisse l'installation?
NB application developpée sous VS 2005.
Merci
A voir également:

4 réponses

Messages postés
6351
Date d'inscription
samedi 1 juin 2002
Statut
Modérateur
Dernière intervention
2 août 2014
84
Salut,

As tu ajouter un installer à ton service ? (clic droit sur la surface de design du service ou le lien en bas de la fenetre de propriétés)

/*
coq
MVP Visual C#
CoqBlog
*/
Messages postés
70
Date d'inscription
mercredi 16 juin 2004
Statut
Membre
Dernière intervention
14 septembre 2015

Bonjour ,
je ne sais pas s'il ya un installer !
il s'agit d'un service windows sans surface de design.
Que faire?
Merci
Messages postés
6351
Date d'inscription
samedi 1 juin 2002
Statut
Modérateur
Dernière intervention
2 août 2014
84
Le fichier source du service apparait comme un fichier de classe "simple" dans l'explorateur de solution ?

/*
coq
MVP Visual C#
CoqBlog
*/
Messages postés
70
Date d'inscription
mercredi 16 juin 2004
Statut
Membre
Dernière intervention
14 septembre 2015

Merci pour votre aide,
en fait j'ai remarqué que  l'application en question était une application console et non un service windows.