Update sur date qui donne 01/01/1900 a chaque fois [Résolu]

Signaler
Messages postés
88
Date d'inscription
mardi 3 mai 2005
Statut
Membre
Dernière intervention
17 septembre 2006
-
Messages postés
88
Date d'inscription
mardi 3 mai 2005
Statut
Membre
Dernière intervention
17 septembre 2006
-
bonjour,

je n'arrive pas a updater correctement une table qui contient des dates

voici ma requete:
UPDATE etre_attribue SET date_deb=16/06/2006, date_sup=12/12/2007, date_exp=31/12/9999
WHERE (id_pers=1 AND id_role=1)

et le resultat donne que ces 3 dates sont updatées à  01/01/1900
j'utilise ca dans un gridview en utilisant ces propriétés la :
DataFormatString

="{0:dd/MM/yyyy}"
ApplyFormatInEditMode="true"
HtmlEncode="false"
quelqu'un connait une solution ?
merci...

3 réponses

Messages postés
88
Date d'inscription
mardi 3 mai 2005
Statut
Membre
Dernière intervention
17 septembre 2006

j'ai enfin trouvé la solution à mon souci :
la requete est bonne
le pb venait du fait qu'un des chamsp parametre (ici, id_role) avait comme propriete Visible

="false"
en le passant à true, tout fonctionne correctement
Messages postés
90
Date d'inscription
lundi 30 juin 2003
Statut
Membre
Dernière intervention
21 février 2008

Et avec des simples ' autour de tes dates? De plus je ne sais pas si il va aimer ta dernière date qui me parait un peu grande pour lui.
Messages postés
88
Date d'inscription
mardi 3 mai 2005
Statut
Membre
Dernière intervention
17 septembre 2006

en fait ma requete sql est
UPDATE etre_attribue SET [mailto:date_deb=@date_deb date_deb=@date_deb], [mailto:date_sup=@date_sup date_sup=@date_sup], [mailto:date_exp=@date_exp date_exp=@date_exp]
WHERE( [mailto:id_pers=@id_pers id_pers=@id_pers] AND [mailto:id_role=@id_role id_role=@id_role])
comme c'est des var, pas besoin de "date" ou 'date'
je retrouve mes var dans le gridview :



<
Columns
>


<asp:BoundField
HeaderText="suppression le..."
DataField="date_sup"
SortExpression="date_sup"
ControlStyle-Width="100px"
DataFormatString="{0:dd/MM/yyyy}"
ApplyFormatInEditMode="true"
HtmlEncode="false"
/>








</
Columns
>
if you 've got an other idea, i'm still stuck...