[débutant] Installer boost sous Windows avec GCC

Messages postés
6
Date d'inscription
samedi 8 juillet 2006
Statut
Membre
Dernière intervention
18 mars 2007
- - Dernière réponse : Sum03
Messages postés
6
Date d'inscription
samedi 8 juillet 2006
Statut
Membre
Dernière intervention
18 mars 2007
- 10 juil. 2006 à 19:02
Bonjour à tous,

Je développe une petite application dans laquelle je dois créer un thread.
Je sais comment faire en Win32 mais je voudrais que cette application soit le plus portable possible (j'ai encapsulé les morceaux de codes non-protables comme la gestion des plugins grâce aux dlls).
J'avais pensé à encapsuler la gestion des threads Win32 aussi mais je me suis dit qu'il serait pas mal d'utiliser une des nombreuses bibliothèques portables et j'ai choisi Boost car j'ai aussi l'intention d'utiliser les regex et les sockets.

Mais je bloque sur l'installation même de boost. J'ai téléchargé boost, je l'ai décompressée eet j'ai essayé de faire ce que me dit de faire la doc avec boost.build.
J'ai généré mon "bjam.exe", mais je n'arrive toujours pas à compiler.
J'utilise GCC  comme compilateur et Code::Blocks comme IDE.
Mon compilateur est dans le dossier "C:/MinGW".
Comment faire pour compiler cette bibliothèque, je pense que je ne met pas les bons paramètres dans le fichier "user-config.jam". De plus je me débrouille très mal avec les lignes de commande.

Merci d'avance de me donner un coup de main!

Spartan03

Pourquoi faire simple quand on peut faire compliqué???
Afficher la suite 

7 réponses

Meilleure réponse
Messages postés
492
Date d'inscription
samedi 10 juillet 2004
Statut
Membre
Dernière intervention
12 janvier 2012
1
1
Merci
Tu n'as absolument aucun fichier a modifier, moi aussi j'utilise Codes::blocks, et c'est passé sans aucun probleme.
Une fois l'installation de Boost terminée, tu ouvre une console, tu va dans le repertoire ou il y a boost et tu fais un
bjam "-sTOOLS=gcc" installcomme indiqué dans la doc (http://www.boost.org/more/getting_started.html). Ensuite tu peux aller fumer une grosse clope parceque la compil prend bien 1h30


TuRn3r

Dire « Merci » 1

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

Codes Sources 207 internautes nous ont dit merci ce mois-ci

Commenter la réponse de turnerom
Messages postés
6
Date d'inscription
samedi 8 juillet 2006
Statut
Membre
Dernière intervention
18 mars 2007
0
Merci
Justement, c'est bien ce que je fait, mais aucune lib n'est compilée.
Les headers sont en revanche, bien copiés.
A chaque fois que bjam essaie de compiler une lib, il est écrit que "g++" n'est pas définie comme une commande interne ou externe, un fichier éxécutable...

Pourquoi faire simple quand on peut faire compliqué???
Commenter la réponse de Sum03
Messages postés
6
Date d'inscription
samedi 8 juillet 2006
Statut
Membre
Dernière intervention
18 mars 2007
0
Merci
D'après ce que j'ai pu voir sur la doc, il faut que je configure bjam.
J'utilise mingw qui est installé dans le dossier c:\program files\CodeBlocks mais je n'arrive pas à combiner les options -sTOOLS=mingw et -sMINGW_ROOT_DIRECTORY=C:\Progra~1\CodeBlocks.
Est-ce que quelqu'un pourrait me dire quoi écrire entre bjam est install dans ma ligne de commande.
Merci d'avance

Pourquoi faire simple quand on peut faire compliqué???
Commenter la réponse de Sum03
Messages postés
492
Date d'inscription
samedi 10 juillet 2004
Statut
Membre
Dernière intervention
12 janvier 2012
1
0
Merci
ah
essaye d'installer les [ gnutools] avant puis tappe juste
bjam "-sTOOLS=mingw" install


TuRn3r
Commenter la réponse de turnerom
Messages postés
492
Date d'inscription
samedi 10 juillet 2004
Statut
Membre
Dernière intervention
12 janvier 2012
1
0
Merci
le lien a foiré, c la : gnuwin32.sourceforge.net

TuRn3r
Commenter la réponse de turnerom
Messages postés
6
Date d'inscription
samedi 8 juillet 2006
Statut
Membre
Dernière intervention
18 mars 2007
0
Merci
Ca ne marche toujours pas

Je vais essaie de repartir à zéro et de faire comme toi, TuRn3r.
Tu es bien sous Windows?!?
Tu utilise bien CodeBlocks avec la version de mingw avec laquelle il est livré?
Il t'as suffit de taper bjam "-sTOOLS=gcc" install?
Où j'ai zapé un truc.

Pourquoi faire simple quand on peut faire compliqué???
Commenter la réponse de Sum03
Messages postés
6
Date d'inscription
samedi 8 juillet 2006
Statut
Membre
Dernière intervention
18 mars 2007
0
Merci
Perso, je pense que c'est normal que mon interpréteur de ligne de commande m'écrive
que g++ n'est pas reconnu en tant que commande interne/externe, un éxécutable ou un batch car je n'ai pas donné à bjam le dossier dans lequel est planqué mingw.
C'est pour ça que j'essaie de combiner deux options.

Pourquoi faire simple quand on peut faire compliqué???
Commenter la réponse de Sum03