Rapport d'erreur [Résolu]

Signaler
Messages postés
255
Date d'inscription
samedi 20 avril 2002
Statut
Membre
Dernière intervention
16 janvier 2007
-
Messages postés
255
Date d'inscription
samedi 20 avril 2002
Statut
Membre
Dernière intervention
16 janvier 2007
-
Salut à tous,
J'ai un problème sans gravité sur une application.
J'ai un code qui fonctionne bien mais il s'affiche rarement une information qui indique un plantage du programme en question.
La fameuse fenêtre "rapport d'erreur" avec l'éventuel envoi (le rapport technique n'esplique rien de facheux).
Pourtant, le programme marche très bien et rien n'affecte l'ensemble des processus. Je ne comprend pas!!!
J'ai repris le code dans tout les sens mais je ne vois pas où se présente le bug qui n'en est pas un d'ailleurs.
Existe-t-il un moyen d'éviter que cette fenêtre s'affiche comme une option de compilation ou une fonction supplémentaire de gestion DeBug?
Merci à tous et ++

2 réponses

Messages postés
255
Date d'inscription
samedi 20 avril 2002
Statut
Membre
Dernière intervention
16 janvier 2007

Oui c'est vrai qu'étrangement j'ai des données qui semble décalées dès le départ, genre une IP qui ne s'inscrit pas et qui est composée de code étrange, un buffer quelques peu instable (...) je vais commencer par ça, tu as raison. merci ++
Messages postés
540
Date d'inscription
vendredi 25 juin 2004
Statut
Membre
Dernière intervention
1 octobre 2007
2
S'il plante parfois c'est surement une variable mal initialisé ou bien des entrés non conformes mais tu nous dit pas exactement quand
ca plante et donc on peut pas savoir ...
Regarde donc si tu as des variables non initialisé ou sinon soumet ton programme a des tests avec differentes entrés enfin compile le en mode debug pour voir ou ca plante..
louis