A l'intention des utilisateurs de Builder : problème d'Alias dans un programme

Signaler
Messages postés
28
Date d'inscription
jeudi 6 avril 2006
Statut
Membre
Dernière intervention
29 juin 2006
-
Messages postés
755
Date d'inscription
samedi 15 mai 2004
Statut
Membre
Dernière intervention
30 janvier 2011
-
Bonjour ,

Comme je l'ais dit dans le titre mon problème concerne l'utilisation d'Alias dans un programme sous Builder C++ , avec utilisation d'une base de donnée Access.

Mon message s'adresse donc en priorité à des connaisseurs car c'est un problème récurrant qui m'embète régulièrement depuis que je conçoit ce programme.

Il n'est pas nécessaire que je définisse ce qu'est un Alias mais peut-être un petit mot sur sa création :
    .Dans panneau de configuration : je suis allé dans l'administrateur de sources de données ODBC
    .j'ai cliqué sur "Ajouter" et sélectionné "Driver do Microsoft Access (*.mdb)"
    .ensuite je lui est définit un nom (MonAlias) et son chemin d'accés
  On retrouve bien cette Alias  dans l'administrateur BDE.
   
Structur du programme:
 
Pour pouvoir travailler sur cette base j' utilise les composants Builder habituels :
TDataSource , TQuery , TDataBase.

Je pense que la configuration de ces composants est bonne.

Dans la propriété "AliasName" j'ai mis le nom de l'Alias que j'ai créé : "MonAlias" et dans la "DataBaseName" le nom de ma base de donnée c'est à dire : bd1 (c'est deux propriétés sont présentent dans le TDataBase).

J'utilise cette structure plusieurs fois dans mon programme avec toujours le même nom d'Alias ("MonAlias") présent  dans la propriété "AliasName" de TDataBase.

Et donc le message d'erreur que j'obtiens régulièrement est :
          "Mémoire insuffisante pour cette opération , Alias : MonAlias".
Il y a un autre problème c'est qu'au bout d'un moment le programme se bloque complètement.

Ces erreurs me pose vraiment problème alors un petit coups de main serait sympa.
Salut.

1 réponse

Messages postés
755
Date d'inscription
samedi 15 mai 2004
Statut
Membre
Dernière intervention
30 janvier 2011

ya toujours des probleme avec builder ;)