Etat avec rave report [Résolu]

codial 270 Messages postés mercredi 14 avril 2004Date d'inscription 5 mai 2015 Dernière intervention - 13 juin 2006 à 19:12 - Dernière réponse : DGPat 54 Messages postés samedi 27 mars 2004Date d'inscription 1 août 2006 Dernière intervention
- 3 juil. 2006 à 12:38
Bonjour,

Pour me familiariser avec rave, j'essaie de faire un état à partir de l'expert  etat/ tableau simple! pas évident!!! j'ai suivi les explications de DelphiProg mais j'ai toujours un problème.

Je réussi bien à faire état car quand je l'exécute à partir de rave il s'affiche normalement.
 Mais quand je le lance avec le code: RvProject1.ExecuteReport('Report1');
et bien il affiche une feuille blanche !!!

Grrrrr !!!

Quelqu'un pourrait m'expliquer pourquoi?

Cordialement

Codial
Afficher la suite 

Votre réponse

3 réponses

Meilleure réponse
cs_jfs59 184 Messages postés mardi 29 avril 2003Date d'inscription 2 février 2010 Dernière intervention - 13 juin 2006 à 19:36
3
Merci
bonsoir ...
il faut évidemment que le rvproject 'pointe' sur le fichier rav que tu as préalablement créé et sauver dans le rave designer
propriété filename ...
ensuite il faut évidemment remplir la propriété des éléments rave que tu souhaite afficher ..
peu etre un bout de ton code nous aiderait a comprendre pourquoi ....ca marche pô

ensuite tu peux aussi charger un exemple qui marche et regarder pourquoi (ou sont les erreurs) le tien marche pas .. des exemples qui marchent y en a la  pelle ...

Cordialement jfs.

Tout est en tout et réciproquement ...

Merci cs_jfs59 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 99 internautes ce mois-ci

Commenter la réponse de cs_jfs59
codial 270 Messages postés mercredi 14 avril 2004Date d'inscription 5 mai 2015 Dernière intervention - 14 juin 2006 à 12:29
0
Merci
Bonjour,

En fait, il pointe bien sur mon fichier rave car quand je mets dans mon état juste un compsant texte il me le restitue bien à l'affichage.

En revanche, c'est quand je créé un état avec l'expert état de rave que ça ne marche pas! Quand je l'exécute avec Rave il s'affiche bien mais quand je la lance avec mon prog il affiche une feuille blanche.
J'ai utilisé le tutorial de delphiprog http://delphipage.free.fr/ravereport.html pour tester, le sien fonctionne mais pas le mien et j'ai beau chercher !!!

Mon code ? ==>   RvProject1.ExecuteReport('Report1');

Cordialement

Codial
Commenter la réponse de codial
DGPat 54 Messages postés samedi 27 mars 2004Date d'inscription 1 août 2006 Dernière intervention - 3 juil. 2006 à 12:38
0
Merci
Bonjour,

Pour afficher une page blanche, il doit manquer quelque chose
vérifie que:
Est ce que dans Rave tu fais bien pointer sur ta base, (le bouton en forme de tambour).
Regarde le nom qui est sur la page ou tu as créé ton etat, c'est ce nom que tu dois mettre dans RvProject1.ExecuteReport('Ici le nom de ta page');
Est ce que tes composants sont sur Active?

Sinon essaie de m'envoyer ton projet, je regarderai, je me sert beaucoup de Rave, et par la même occasion si cela peut aider d'autre dans l'utilisation de logiciel.

bonne journée

Ce n'est pas parce qu'on débute que l'on est forcement idiot
DGPat
Commenter la réponse de DGPat

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.