Galère sur le test d'une valeur d'une cellule dans Excel

Résolu
Maxou le petit
Messages postés
47
Date d'inscription
jeudi 16 juin 2005
Statut
Membre
Dernière intervention
21 mai 2007
- 8 mai 2006 à 16:48
mortalino
Messages postés
6786
Date d'inscription
vendredi 16 décembre 2005
Statut
Membre
Dernière intervention
21 décembre 2011
- 11 mai 2006 à 06:19
Bonjour;

Petit problème. Je dois effectuer un test sur la valeur d'une cellule dans laquelle il y a une formule. Quel code dois je utiliser pour effectuer ce test sur le résultat de la cellule ?
Actuellement j'utile "Cellule.value" mais mon test ne fonctionne pas ?

Merci pour l'aide

A+

7 réponses

mortalino
Messages postés
6786
Date d'inscription
vendredi 16 décembre 2005
Statut
Membre
Dernière intervention
21 décembre 2011
18
10 mai 2006 à 08:03
Salut,

Je viens de tester les résultats avec Cells & Range .Value
C'est bien le valeur que l'on récupère et non la formule, donc ça devrait fonctionner.

Par contre, dans ton code :
If Cells(Compteur, 9).Value = "" And Cells(Compteur, 10).Value <> "x"
le x est en minuscule
et dans ta formule,
=SI(ESTERREUR(RECHERCHEV(A18;MP!$A$2:$F$249;6;FAUX));"";"X")
il est en majuscule ?!

C'est peut-être ça

@ ++
Mortalino
3
Salade007
Messages postés
76
Date d'inscription
dimanche 30 novembre 2003
Statut
Membre
Dernière intervention
30 janvier 2019

8 mai 2006 à 18:00
bonjour,
essai ceci

dim test as integer (pour creer ta variable)
la ligne de code au moment du test
Range("la cellule à test ex A2").Select
test = Selection.Value






à++++++++[8D]
0
Maxou le petit
Messages postés
47
Date d'inscription
jeudi 16 juin 2005
Statut
Membre
Dernière intervention
21 mai 2007

8 mai 2006 à 18:52
Désolé je n'ai pas bien compris, mais je découvre VBA, voilà un extrait de mon code mon code :

Sub Archivage1()
Dim Cellule, DerniereLigne, Compteur
Range("A3").Select
DerniereLigne = ActiveSheet.UsedRange.Row - 1 + _
ActiveSheet.UsedRange.Rows.Count
For Compteur = DerniereLigne To 3 Step -1
If Cells(Compteur, 9).Value = "" And Cells(Compteur, 10).Value <> "x" Then 'C'est pour cette 2°condition que j'ai un PB en fait dans la cellule il y a une formule qui me renvoie la valeur "x" , je voudrai comme pour la première condition qui n'est pas issue d'une formule que si la valeur est différente de "x" alors delete...
Rows(Compteur).Delete
End If
Next Compteur 'Ligne suivante intruction liée à for
Range("A1").Activate
End Sub

D'avance Merci
0
mortalino
Messages postés
6786
Date d'inscription
vendredi 16 décembre 2005
Statut
Membre
Dernière intervention
21 décembre 2011
18
8 mai 2006 à 23:05
Salut,

J'avoue que je comprends pas trop le truc du "x". C'est une valeur fictive ??
Tu parles de formule, donne nous un exemple de la formule qui est mise dans la cellule et le résultat qui s'affiche à l'écran.

Et tu veux supprimer par rapport à quoi : la formule ou le résultat ?

@ ++
Mortalino
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Maxou le petit
Messages postés
47
Date d'inscription
jeudi 16 juin 2005
Statut
Membre
Dernière intervention
21 mai 2007

9 mai 2006 à 05:53
Par rapport au résultat !

La formule dans la cellule en question est la suivante :
=SI(ESTERREUR(RECHERCHEV(A18;MP!$A$2:$F$249;6;FAUX));"";"X")

Merci pour votre patience !
0
Maxou le petit
Messages postés
47
Date d'inscription
jeudi 16 juin 2005
Statut
Membre
Dernière intervention
21 mai 2007

11 mai 2006 à 06:00
Bonjour;

C'est effectivement cela ça marche. En fait c'était simple. Merci pour ce coup de main tu m'enlèves une épine du pied.

Mon code était juste mes j'ai fait une erreur de débutant, ce que je suis du reste !

A+
0
mortalino
Messages postés
6786
Date d'inscription
vendredi 16 décembre 2005
Statut
Membre
Dernière intervention
21 décembre 2011
18
11 mai 2006 à 06:19
Y'a pas de problème, tout le monde a eu le tour (même encore maintenant), à une virgule près, ça plante.

Bon courage pour la suite.

@ ++
Mortalino
0