Pb getimagesize [Résolu]

Signaler
Messages postés
214
Date d'inscription
lundi 20 mars 2006
Statut
Membre
Dernière intervention
23 juin 2006
-
Messages postés
214
Date d'inscription
lundi 20 mars 2006
Statut
Membre
Dernière intervention
23 juin 2006
-
bonjour à tous,
je voudrais uploader une image après l'avoir redimensionnée en gardant les propoertions. j'ai regardé dans les différentes sources proposées, et je me suis lancé dans la création de ma propre fonction. le probleme, c'est que je veux utiliser la fonction getimagesize afin de recuperer les dimensions de l'image, et voila ce qui s'affiche:
Warning: getimagesize(C:\Documents and Settings\David\Bureau\iles.jpg): failed to open stream: No such file or directory in /home/httpd/vhosts/nomdedomaine/httpdocs/truc.php on line 25
je me suis renseigné sur le net pour voir, et j'ai vu qu'il fallait activer une librairie gd en modifiant le php.ini (il faut enlever un commentaire à une certaine ligne). Mais dans mon php.ini, je n'ai pas cette ligne commenté, et je n'ose pas trop la rajouter de peur de ne pas la mettre au bon endroit. sur mon phpinfo j'ai:
GD Support enabled
GD Version bundled (2.0.28 compatible)
voila, alors que puis-je faire? la librairie est-elle déjà installé (je pense que oui vu les deux lignes précédentes)?puis-je ajouter dans mon php.ini la ligne de commande que j'ai trouvé, et ce n'importe ou dans le fichier?
Merci d'avance
David
A voir également:

3 réponses

Messages postés
10840
Date d'inscription
lundi 24 février 2003
Statut
Modérateur
Dernière intervention
2 mars 2010
23
Hello,

le problème n'est pas que ta GD N'est pas installé, mais que getimagesize ne trouve pas ton image au chemin que tu lui indiques.
Messages postés
214
Date d'inscription
lundi 20 mars 2006
Statut
Membre
Dernière intervention
23 juin 2006

je précise au cas ou cela aurait son importance que ma version de php est 4.3.10
Messages postés
214
Date d'inscription
lundi 20 mars 2006
Statut
Membre
Dernière intervention
23 juin 2006

je te remercie de t'etre penché sur mon sujet.
effectivement, le chemin était incorrect... je pensais, en voyant le message d'erreur, que c'était la fonction qu'il ne reconnaissait pas. Pourtant effectivement c'est bien marqué '...such file or directory' et non pas unknown function. Excusez moi pour cette erreur de lecture, qui m'a quand meme couté 1 heure de panique.
Merci encore
David