Erreur au linkage

Signaler
Messages postés
80
Date d'inscription
jeudi 2 février 2006
Statut
Membre
Dernière intervention
24 mai 2007
-
Messages postés
14
Date d'inscription
jeudi 30 août 2007
Statut
Membre
Dernière intervention
17 novembre 2009
-
Bonjour à tous

Voilà j'ai un ptit soucis avec des méthodes que j'appelle et qui se trouvent dans un .lib, je charge bien le .lib (méthode pragma (comment, "malib.lib")).

Au link j'ai 3 erreurs

error LNK2028: jeton non résolu (0A00000A) "void __cdecl ctdStopDriver(void)"
([mailto:?ctdStopDriver@@$$FYAXXZ ?ctdStopDriver@@$$FYAXXZ]) référencé dans la fonction "void __clrcall AllegroConnexion::ConnexionAllegro::Stop(void)"
([mailto:?Stop@ConnexionAllegro@AllegroConnexion ?Stop@ConnexionAllegro@AllegroConnexion]@@$$FQ$AMXXZ)

error LNK2019: symbole externe non résol "void __cdecl ctdStopDriver(void)"
([mailto:?ctdStopDriver@@$$FYAXXZ ?ctdStopDriver@@$$FYAXXZ]) référencé dans la fonction "void __clrcall AllegroConnexion::ConnexionAllegro::Stop(void)"
([mailto:?Stop@ConnexionAllegro@AllegroConnexion ?Stop@ConnexionAllegro@AllegroConnexion]@@$$FQ$AMXXZ)

fatal error LNK1120: 2 externes non résolus.

Si vous pouviez me donner quelques infos ....

Merci

Z.

1 réponse

Messages postés
14
Date d'inscription
jeudi 30 août 2007
Statut
Membre
Dernière intervention
17 novembre 2009

Hello z_san,

Je viens de tomber sur ton message, je pense qu'en 2 et demi tu as pu trouver une solution, en tout cas j'espère que oui.
Cela dit, si quelqu'un tombe sur ce thread en ayant le même problème, ça peut toujours servir...
Il m'est arrivé la même chose, et je me suis arraché les cheveux avec ces histoires de managé/non-mangé.
J'ai essayé plein de trucs (inclure des librairies notamment, changer les options de compilation...) mais en fait j'avais simplement oublié de définir les constructeurs.