Formule dans Excel avec VB6 [Résolu]

Messages postés
710
Date d'inscription
jeudi 20 février 2003
Dernière intervention
19 mai 2015
- 6 avril 2006 à 11:13 - Dernière réponse :
Messages postés
710
Date d'inscription
jeudi 20 février 2003
Dernière intervention
19 mai 2015
- 7 avril 2006 à 00:10
bonjour
à l'aide d'un bouton je vais cherché un fichier texte sur mon DD et je le valide pour le transformé en fichier excel.
Comment faire pour :
1)une fois que le fichier texte est transformé en Excel se lance automatiquement à la fin de la transformation.
2) et comment lui mettre se code (si dessous) dans le Workbook_Open pour le faire executé au lancement du fichier Excel.

Feuil1.Range("a2:E50").Sort Key1:=Feuil1.Columns(3) 'tri des colonnes
Feuil1.Range("H2:H50").FormulaR1C1 = "=""<""&30/24/60/60"
Feuil1.Range("F3:F50").Formula = "=(C3=C2)*(B3-B2)"
Feuil1.Range("I2").Select 'nbrs de défauts
ActiveCell.FormulaR1C1 = _
"=COUNTIF(RC[-3]:R[48]C[-3],RC[-1])-COUNTIF(RC[-3]:R[48]C[-3],0)" '=NB.SI(F2:F50;H2)-NB.SI(F2:F50;0)
Feuil1.Range("F3:F50").NumberFormat = "[s]"
Columns("F:K").ColumnWidth = 0 'colonnes cachées
Dim MAVALEUR As String
MAVALEUR = Range("I2").Value
MsgBox " Défauts < 30s est de " & vbCrLf & MAVALEUR, vbExclamation, "Nbrs de défauts inférieur à 30s"
Range("A1").Select
merci
@plus
petchy
Afficher la suite 

3 réponses

Meilleure réponse
Messages postés
7401
Date d'inscription
mercredi 23 avril 2003
Dernière intervention
6 avril 2012
- 6 avril 2006 à 11:37
3
Merci
Salut,

Correction tu n'as meme pas besoin de Excel.Application pour lancer Excel:

Un simple

Dim WB as Excel.WorkBook
Set WB = Excel.WorkBooks.OPen("C:\TEst.Xls") Suffit pour ouvrir ton classeur

Ensuite pour acceder aux feuille

WB.Sheets("Feuil1")

Etc..

@+, Julien
Pensez: Moteur de Recherche, Réponse Acceptée

Merci jrivet 3

Avec quelques mots c'est encore mieux Ajouter un commentaire

Codes Sources a aidé 90 internautes ce mois-ci

Messages postés
7401
Date d'inscription
mercredi 23 avril 2003
Dernière intervention
6 avril 2012
- 6 avril 2006 à 11:31
0
Merci
Salut,

Si tu ajoutes a ton programme VB6 la référence: Microsoft Excel 9.0 Object Library, Tu pourras utiliser les objets.

Excel.Application (pour lancer excel)
Excel.WorkBook pour le classeur
Etc...

Ensuite je pense que le code que tu as mis pourra etre directement dans l'appli VB6

@+, Julien
Pensez: Moteur de Recherche, Réponse Acceptée
Messages postés
710
Date d'inscription
jeudi 20 février 2003
Dernière intervention
19 mai 2015
- 7 avril 2006 à 00:10
0
Merci
salut Julien
merci pour ta réponse
petchy

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes et codes sources.

Le fait d'être membre vous permet d'avoir des options supplémentaires.