BASSVIDEO : LECTEUR VIDEO AVEC BASS

Signaler
Messages postés
992
Date d'inscription
jeudi 2 novembre 2000
Statut
Membre
Dernière intervention
24 avril 2013
-
Messages postés
992
Date d'inscription
jeudi 2 novembre 2000
Statut
Membre
Dernière intervention
24 avril 2013
-
Cette discussion concerne un article du site. Pour la consulter dans son contexte d'origine, cliquez sur le lien ci-dessous.

https://codes-sources.commentcamarche.net/source/48975-bassvideo-lecteur-video-avec-bass

Messages postés
992
Date d'inscription
jeudi 2 novembre 2000
Statut
Membre
Dernière intervention
24 avril 2013
2
Désolé Double post !
J'ai pigé mon problème en me relisant !
j'avais tout simplement un problème de CODEC .

C'est réglé , je poste la MAJ
Messages postés
992
Date d'inscription
jeudi 2 novembre 2000
Statut
Membre
Dernière intervention
24 avril 2013
2
Merci ,

Ok pour la scrollbar, c'est une idée...
Par contre % à la capture en Jpeg pas d'idées !

function BassVideo_CaptureBitmap(lpSourceFile : Pointer; CaptureTime : Double; BitmapOutput : Pointer; Flags : DWORD) : BOOL; stdcall;

Parameters

SourceFile [in] Video input file name
CaptureTime [in] Position to capture
BitmapOutput [in] Output bmp file
Flags [in] BASS_UNICODE for Unicode file name

Au début je pensais que BitmapOutput était un Bmp
(donc possibilité de le mettre en jpeg contribuant une petite bidouile)
mais ce n'est qu'un PathName !
La seul solution (je pense) serais en même temps d'enregistrer ma Frame, je l'ouvre dans un nouveau Bitmap
(je connais son nom et son emplacement),
je sauvegarde en Jpeg avec le même nom et j'efface le Bmp...
Mais ça risque de fort ralentir le processus (pas pour une capture mais pour 100 ...)

J'ai fait une MAJ mais j'ai un petit problème (en fait un gros!) :
je me suis acheté une nouvelle carte son : Creative sound blaster Audigy SE.

Depuis que je l'utilise , mon son lague à mort (juste pour cette source, sinon ça me ferait bien **** ;) )

J'ai réussi à trouver un remède (cfr l'aide et le format flv)
Mais le problème, c'est que l'attrait de la source tombe à zéro vu que je dois désactiver la gestion du son avec BASS (ce qui veut dire égaliseur et effet inutiles ici , d'ailleurs le nouveau egaliseur est à 10 bandes et est mieux géré : il y a un beug dans cette source ci , quand on ouvre une nouvelle vidéo, l'égaliseur même activé, ne s'active pas)

Si tu veux je la poste et tu me dis si ca marche !
(J'ai quand même pas de bol sur ce coup la , et même leur démo officielle plante royalement ! )

Nico
Messages postés
460
Date d'inscription
dimanche 5 décembre 2004
Statut
Membre
Dernière intervention
6 avril 2009
2
Bonjour à toutes et à tous,

@ Nicolas___, super cette source, n'oublies pas de préciser pour celui qui n'a pas XPMAN de l'enlever de l'Uses.
Pour la capture de la frame en bmp, peut être prévoir aussi le jpg.

Pour le défilement frame par frame, un scrollbar me semble aussi utile.

Sinon sur D6, c'est correct.

@+,

Cincap
Messages postés
992
Date d'inscription
jeudi 2 novembre 2000
Statut
Membre
Dernière intervention
24 avril 2013
2
Dernière petite remarque : Il faut posséder les codecs pour pouvoir décoder les vidéos ...