[WMI][C++][DEV-C++] LECTURES D'INFORMATIONS AVEC WMI SOUS DEVCPP

Signaler
Messages postés
2
Date d'inscription
lundi 11 août 2008
Statut
Membre
Dernière intervention
5 novembre 2008
-
devluc
Messages postés
1
Date d'inscription
mardi 11 janvier 2011
Statut
Membre
Dernière intervention
12 janvier 2011
-
Cette discussion concerne un article du site. Pour la consulter dans son contexte d'origine, cliquez sur le lien ci-dessous.

https://codes-sources.commentcamarche.net/source/47919-wmi-c-dev-c-lectures-d-informations-avec-wmi-sous-devcpp

devluc
Messages postés
1
Date d'inscription
mardi 11 janvier 2011
Statut
Membre
Dernière intervention
12 janvier 2011

Thanks a lot!
cs_omnia
Messages postés
240
Date d'inscription
jeudi 9 janvier 2003
Statut
Membre
Dernière intervention
22 mars 2009

Effectivement :p

pour les includes : j'avais fait sa pour ceux qui utilisaient DEVcpp.

pour SecurityCenter2, oui tout a fait pour info c'est documenté sur le msdn de Microsoft.

bon codage
scoubidou944
Messages postés
728
Date d'inscription
mardi 22 avril 2003
Statut
Membre
Dernière intervention
19 janvier 2017

J'ai remplacé:
#include "WbemCli.h"
#include "wbemprov.h"
#include "wbemtran.h"

par :
#include <Wbemcli.h>
(j'ai donc supprimé les 3 fichiers en question du projet puisque l'on peut utiliser ceux de VS 2008 Express).

L"ROOT\\SecurityCenter" a été remplacé par L"ROOT\\SecurityCenter2" sur Vista SP1+ il semblerait (je confirme qu'il faut prendre la 2ème version pour 7 Pro pour ne pas avoir des champs vides.
cs_omnia
Messages postés
240
Date d'inscription
jeudi 9 janvier 2003
Statut
Membre
Dernière intervention
22 mars 2009

Bonjour,

si ton but est de la communication tu recherche au mauvais endroit, si ce n'est que pour le statut, ton périphérique est visible en USB et non série.
tutu91
Messages postés
2
Date d'inscription
lundi 11 août 2008
Statut
Membre
Dernière intervention
5 novembre 2008

Salut

J'ai un pb avec WMI.
J'utilise un adaptateur USB serie et je voudrais récupérer le status du port série. Mais l'adaptateur USB serie n'apparait pas dans la classe Win32_serialport.
Quelqu'un peut-il me dire comment faire?