REQUETE HTTP GET / POST

Signaler
Messages postés
1447
Date d'inscription
jeudi 2 novembre 2000
Statut
Membre
Dernière intervention
23 septembre 2007
-
blq
Messages postés
97
Date d'inscription
vendredi 22 octobre 1999
Statut
Membre
Dernière intervention
13 juin 2016
-
Cette discussion concerne un article du site. Pour la consulter dans son contexte d'origine, cliquez sur le lien ci-dessous.

https://codes-sources.commentcamarche.net/source/36181-requete-http-get-post

blq
Messages postés
97
Date d'inscription
vendredi 22 octobre 1999
Statut
Membre
Dernière intervention
13 juin 2016
1
Juste pour information :
cela fonctionne très bien avec Visual Basic Express 2010 sur un site en accès HTTP, parcontre j'ai une erreur avec un accès HTTPS "impossible d'établir une relation de confiance pour la canal sécurité SSL/TLS".

Je n'ai pas encore cherché à résoudre ce souci...
fabulofr
Messages postés
116
Date d'inscription
lundi 15 décembre 2003
Statut
Membre
Dernière intervention
8 novembre 2011
1
Solution trouvée, si d'autres ont ce souci:
J'avais ajouté une ligne dans mon projet:
hwebrequest.SendChunked=true.
J'ai mis à false et ça roule.

Par contre, j'ai beau mettre :
Dim readstr = New IO.StreamReader(hwebresponse.GetResponseStream, System.Text.Encoding.Default) ou tout autre encodage, j'ai toujours un ? dans un losange.
Coté PHP, que je fasse :
header('Content-Type: text/html; charset=ISO-8859-1');
ou
header('Content-Type: text/html; charset=UTF-8');

Ca ne change strictement rien :-(

Je reste bloqué sur de *ù$^$ù*$^*ùù de truc d'accents ça saoule xD
fabulofr
Messages postés
116
Date d'inscription
lundi 15 décembre 2003
Statut
Membre
Dernière intervention
8 novembre 2011
1
Hello !
De retour avec la version 2010 de vb.net express, j'essaye de reprendre un vieux projet que je réalisais sous 2008 ou 2005 je sais plus. bref.
La ligne "Dim hwebresponse As System.Net.HttpWebResponse = hwebrequest.GetResponse 'on crée un objet de reponse a notre requete " me rapporte une erreur:
"L'exception ProtocolViolationException s'est produite: Content-Length ou l'encodage mémorisé ne peut pas être défini pour une opération ne permettant pas l'écriture de données."

WTF ?_?
FGHDRAGON
Messages postés
1
Date d'inscription
jeudi 16 décembre 2010
Statut
Membre
Dernière intervention
14 juin 2011

salut,
j'ai essayé ce code pour se connecter sur facebook et ca n'a pas marché :(
un petit help svp
Afficher les 74 commentaires