SQL SERVER - PROCÉDURE STOCKÉE FAISANT UN BACKUP DE TOUTES LES BASES ET JOURNAUX

Signaler
Messages postés
45
Date d'inscription
lundi 23 juin 2003
Statut
Membre
Dernière intervention
24 février 2009
-
kraps04
Messages postés
3
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
16 janvier 2012
-
Cette discussion concerne un article du site. Pour la consulter dans son contexte d'origine, cliquez sur le lien ci-dessous.

https://codes-sources.commentcamarche.net/source/29625-sql-server-procedure-stockee-faisant-un-backup-de-toutes-les-bases-et-journaux-de-transaction-automatiquement

kraps04
Messages postés
3
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
16 janvier 2012

Bonjour,
j'ai testé cette procédure qui fonctionne très bien , seulement moi j'ai décidé d'en faire 2 procédures , une pour la sauvegarde des bases de données et une pour les journaux des transactions afin de sauvegarder les journaux plus régulièrement que les bases .
J'ai donc essayer de rajouter l'heure aux nom des fichier de sauvegardes des logs ,mais en vain ,l'heure s'écrivant sous cette forme HH:MM:SS ,les : ne sont pas utilisable dans un nom de fichier .. si vous auriez une réponse pour me venir en aide s'il vous plait .. merci
cs_fabrice69
Messages postés
1765
Date d'inscription
jeudi 12 octobre 2000
Statut
Modérateur
Dernière intervention
11 décembre 2013
4
Bonjour,
Dans ce cas, il faut mettre le nom de la base entre crochets [xxxxxxx]
Cordialement
Fabrice Romelard [MVP]
scub82
Messages postés
2
Date d'inscription
samedi 2 juillet 2005
Statut
Membre
Dernière intervention
24 octobre 2014

Bonjour,
J'ai testé cette procédure qui marche très bien néanmoins j'ai un problème concernant une des bases. Le back up ne se fait pas car il semble que le nom de a base comporte un espace.
Il y a t il un moyen de régler ce problème?

merci d'avance.
cs_fabrice69
Messages postés
1765
Date d'inscription
jeudi 12 octobre 2000
Statut
Modérateur
Dernière intervention
11 décembre 2013
4
Bonjour,
Cela vient du fait que cette procédure utilise après la sauvegarde un module de compression (standard sous Windows - MakeCab).
Pour exécuter cette commande, on doit utiliser la procédure system de SQL Server "dbo.xp_cmdshell" qui permet d'exécuter des fichiers exécutable dans le contexte SQL Server.
Cette procédure stockée est désactivée de base sous SQL Server 2005 et 2008. Il vous faut chercher dans les options pour la réactiver (je ne me souviens plus exactement ou mais ca doit être dans l'outil danalyse de la surface de mémoire).

Si vous ne voulez pas être géné avec ca, il suffit de désactiver (commentaire devant la ligne -- souc SQL Server) les lignes 129 et 134

Cordialement
Romelard Fabrice [MVP]