CRYPTAGE ET DÉCRYPTAGE DE CHAINE

Signaler
Messages postés
1106
Date d'inscription
samedi 8 novembre 2003
Statut
Membre
Dernière intervention
3 septembre 2006
-
Messages postés
1
Date d'inscription
mercredi 7 décembre 2011
Statut
Membre
Dernière intervention
15 avril 2012
-
Cette discussion concerne un article du site. Pour la consulter dans son contexte d'origine, cliquez sur le lien ci-dessous.

https://codes-sources.commentcamarche.net/source/29106-cryptage-et-decryptage-de-chaine

Messages postés
1
Date d'inscription
mercredi 7 décembre 2011
Statut
Membre
Dernière intervention
15 avril 2012

je le voir et apres je te repponds
Messages postés
1
Date d'inscription
jeudi 5 juin 2008
Statut
Membre
Dernière intervention
4 novembre 2010

Procedure cryptage(ch : chaine ; var ch2 : chaine)
Résultat = ch2
ch2 = [ch2 <-- "" ; c <-- ch[1] ; cpt <-- 1]
Pour i de 2 à Long(Ch) Faire
Si ch[i] = c Alors
cpt <-- cpt + 1
Sinon
ConvCh(cpt, ch3)
ch2 <-- ch2 + ch2 + c
cpt <-- 1
c <-- ch[i]
Fin Si
Fin Pour
ConvCh(cpt, ch3)
ch2 <-- ch2 + ch2 + c
Messages postés
3826
Date d'inscription
vendredi 23 juillet 2004
Statut
Modérateur
Dernière intervention
10 mai 2021
42
Dans ce cas tu es au bon endroit ... et je souhaite la bienvenue parmi nous.

Mais je te conseil de bien lire le règlement afin d'éviter à l'avenir ce genre de question qui sont, normalement, totalement interdites et sanctionnées immédiatement.

Pour le forum c'est pareil et avant de poser une question il faut faire une recherche avec le moteur du site et/ou Google ... en effet, plus 90% des questions de débutant on déjà trouvées réponses, il n'est donc plus utile de les reposer.

Voilà bonne chance pour la suite ... ;)
Messages postés
2
Date d'inscription
lundi 7 avril 2008
Statut
Membre
Dernière intervention
7 avril 2008

je vous remerçi de votre reponse mais je ne veux pas devenir pirates mais je voudrez devenir et surtout savoir crée des programmes
Afficher les 13 commentaires