BALISE XITI AUTOMATIQUE - WEBCONTROLE PERMETTANT D'INSÉRER LE CODE XITI ET DE LE

Signaler
Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
-
Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
-
Cette discussion concerne un article du site. Pour la consulter dans son contexte d'origine, cliquez sur le lien ci-dessous.

https://codes-sources.commentcamarche.net/source/25531-balise-xiti-automatique-webcontrole-permettant-d-inserer-le-code-xiti-et-de-le-parametrer-tres-rapidement

Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
29
ok j'ai moi aussi survoler le code, j'ai vu que c'etait tres bien réalisé, mais je m'en suis pas servis, juste vite fait sur un projet et j'ai vu l'erreur :)

En tout cas ton projet va m'etre tres utile et je ne pense pas etre le seul dans ce cas
Messages postés
276
Date d'inscription
dimanche 22 juillet 2001
Statut
Modérateur
Dernière intervention
5 décembre 2013

En effet, je suis entrain de matter ce pb depuis 1heure là. Enfaite c'est l'attribut
ToolboxBitmap("xiticontrol.bmp")
dans la déclaration de la classe XitiControl. J'ai lu ça dans le boukin Microsoft, c'est la methode à suivre pour affecter une image au controle quand il se trouve dans la boite d'outils. En mode design ça fonctionne, mais j'avais pas encore executé (pour gagner du temps je me disais que c'étais la même chose...)

Je posterais la maj quand j'aurais trouvé.

Au fait, je me suis rendu compte que j'avais oublié d'activer le positionnement sur la page de la balise ...

Je mettrais tout ça à jour bientot
Messages postés
6814
Date d'inscription
dimanche 15 décembre 2002
Statut
Modérateur
Dernière intervention
13 octobre 2010
29
Excellent :)

Je devais justement faire un control de ce genre pour Xiti cette semaine, mais j'aurais gagné qq minutes de code.
en tout cas je trouve ton code tres clean, tres pro!
Tu es un exemple a suivre :p

J'ai juste eu un petit problème : j'ai ajouté la dll dans le dossier bin, fait reference etc .. comme qd j'ajoute un composant, sauf que j'ai eu un message d'erreur concernant XitiControl.bmp : FilenotFoundException je crois, j'ai placé l'image dans le dossier bin, mais idem :( j'ai supprimé la ligne faisant reference à l'image et plus de problème :) mais ce serait bien de jeter un oeil la dessus

J'ai rien d'autre à rajouter la dessus, ce controle est tres utile, bien fait, on peut rien lui demander de mieux :) ca merite un 8/10

Bonne continuation

Cyril