DEVBLOG: BLOG-SYSTEM POUR LES DEVELOPPEURS @VERSION->0.2.2

lumesh
Messages postés
564
Date d'inscription
jeudi 21 février 2002
Statut
Membre
Dernière intervention
7 novembre 2008
- 16 août 2004 à 09:50
cs_jo38
Messages postés
1
Date d'inscription
mercredi 21 mai 2003
Statut
Membre
Dernière intervention
23 juin 2009
- 23 juin 2009 à 02:22
Cette discussion concerne un article du site. Pour la consulter dans son contexte d'origine, cliquez sur le lien ci-dessous.

https://codes-sources.commentcamarche.net/source/25434-devblog-blog-system-pour-les-developpeurs-version-0-2-2

cs_jo38
Messages postés
1
Date d'inscription
mercredi 21 mai 2003
Statut
Membre
Dernière intervention
23 juin 2009

23 juin 2009 à 02:22
Salut
Merci beaucoup pour cette source,
mais pourrais tu me dire comment insérer une photo dans le message du blog?
BlackWizzard
Messages postés
1258
Date d'inscription
mercredi 21 mars 2001
Statut
Membre
Dernière intervention
21 juin 2009
2
3 sept. 2008 à 16:14
ça a plus de 4 ans, ce n'est pas a jour du tout... Désolé!
titou_hello
Messages postés
24
Date d'inscription
jeudi 13 avril 2006
Statut
Membre
Dernière intervention
10 novembre 2008

3 sept. 2008 à 15:30
Ce CMS est toujours d'actualité niveau sécurité?
Epoc22
Messages postés
198
Date d'inscription
lundi 28 février 2005
Statut
Membre
Dernière intervention
14 novembre 2008
1
9 janv. 2007 à 15:58
C'est normal que le lien http://blog.blackwizzard.net/data.php?id=19 fonctionne pas ?
cs_iubito
Messages postés
629
Date d'inscription
mercredi 3 juillet 2002
Statut
Membre
Dernière intervention
9 octobre 2006

23 août 2004 à 07:22
Waouw ! beau travail, et ça fait une petite démo de phpbeautifuler, parce que sur leur site les démos sont hyper pourries !!!
Faudrait que j'essaye ça !
BlackWizzard
Messages postés
1258
Date d'inscription
mercredi 21 mars 2001
Statut
Membre
Dernière intervention
21 juin 2009
2
21 août 2004 à 01:50
nouvelle version released:
version 0.2.4s

liste des fonctions et dl: http://blog.blackwizzard.net/data.php?id=19
BlackWizzard
Messages postés
1258
Date d'inscription
mercredi 21 mars 2001
Statut
Membre
Dernière intervention
21 juin 2009
2
17 août 2004 à 22:19
ok, je ferai ça pour la 0.2.4.
de nouveaux il y aura
gestion des smileys,
word-replacement,
module de liens (affichage de liens classés sur le coté),
lecteur de flux rdf 0.9 en bas de l'index
tout ça parametrable depuis l'admin.
demo actualisé toutes les nuits selon l'avancement:
www.blackwizzard.net
cs_windu
Messages postés
282
Date d'inscription
vendredi 16 mai 2003
Statut
Membre
Dernière intervention
19 juillet 2006

17 août 2004 à 21:21
c'est bon, j'ai trouvé où était mon pb: certaines de tes balises sont <? et d'autres <?php... or j'ai configuré de façon à n'accepter que <?php, d'où mon problème!!! je te conseille de changer tes balises en <?php comme le conseille Grenard (http://www.phpcs.com/code.aspx?ID=24870) sur son tutorial sur la programmation propre...
lumesh
Messages postés
564
Date d'inscription
jeudi 21 février 2002
Statut
Membre
Dernière intervention
7 novembre 2008

17 août 2004 à 15:31
g mis le nez dedans et je t'avoue je ne vois pas d'ou vient le pb .... la connexion SQL se fait bien (depuis que j'ai compris le truc des var local et remote) ...
BlackWizzard
Messages postés
1258
Date d'inscription
mercredi 21 mars 2001
Statut
Membre
Dernière intervention
21 juin 2009
2
17 août 2004 à 15:03
le login a l'admin fonctionne avec sql... donc si il etablit pas la connection en local ça marchera pas...
si ça ne focntionne pas malgres la connection, alors c'est un probleme du aux ipCookies (/devlib/data/ipCookies.php)
ce que je ne comprend pas, c'est que les ip cookies fonctionnent en associant une variable et une valeur à une ip dans uen base sql, dans le but d'eviter de poser un cookie et tous les problemes qui vont avec (navigateur avec cookies off)
chez moi, malgres mes test en local et en remote, je n'ai aucuns problemes...
lumesh
Messages postés
564
Date d'inscription
jeudi 21 février 2002
Statut
Membre
Dernière intervention
7 novembre 2008

17 août 2004 à 09:53
petit retour:

- pas de pb pour installer le script mais emmelage de pinceaux avec les renseignement de conf.php
mon serveur est local, donc je renseigne les variables locales ... mais non ce sont les remotes qui sont utilisées !!!!

- sinon impossible de m'identifier dans l'admin ...
le login et pass dans la table 'user" ne fonctionnent pas meme si je les modifie. pas de message d'erreur rien, juste un retour au formulaire ... emmerdant.

Donc tout ce que l'on peut voir quand ca vient juste detre installé fonctionne sous PHP5 mais apres mystere :)
lumesh
Messages postés
564
Date d'inscription
jeudi 21 février 2002
Statut
Membre
Dernière intervention
7 novembre 2008

17 août 2004 à 09:40
si il n'ya pas de fioriture dans le script, normalement ca doit passer sous PHP5.
Je vais DL le code et testouiller sur un serveur PHP5.
Je tiens au courant.
BlackWizzard
Messages postés
1258
Date d'inscription
mercredi 21 mars 2001
Statut
Membre
Dernière intervention
21 juin 2009
2
17 août 2004 à 00:26
a_valueof() est defini dans le fichier /devlib/mysql/easyQuery.php
verifie que ce fichier est bien chargé
.index.php inclus le fichier devlib/libbw.php :require_once("devlib/libbw.php");
qui lui inclus /devlib/mysql/easyQuery.php

donc, si tu n'as touché a rien d'autre que ce qui est dit dans l'installation, je comprend pas...
incopatibilité avec ta version de php peut-etre? je n'ai pas testé sous php5...

Le script d'installation est prevu maus pour dans 2 semaines, pas avant etant donné le boulot que j'ai a coté de ce projet...
cs_windu
Messages postés
282
Date d'inscription
vendredi 16 mai 2003
Statut
Membre
Dernière intervention
19 juillet 2006

16 août 2004 à 19:59
salut, juste une question!
Je sais pas si c'est moi qui sais pas m'y prendre ou si il y a 1 problème, mais quand je lance le fichier index.php (celui le plus à la racine du site), j'obtiens le message d'erreur suivant: "Call to undefined function: a_valueof() in ...". Pourtznt j'ai suivi tes consignes d'installation, j'ai créé la BDD sous le nom "bw" (vu que c'est le nom inscrit par défaut dans ton fichier conf.php), j'ai exécuté le fichier queries.sql, j'ai bien les fonctions java script et php en place... je comprends pas!
lumesh
Messages postés
564
Date d'inscription
jeudi 21 février 2002
Statut
Membre
Dernière intervention
7 novembre 2008

16 août 2004 à 09:50
code-beautifier , un exelent script de colo synthaxique. Je ne c meme pas s'il existe mieux en PHP !